poj-2151 Check the difficulty of problems 概率+DP

12 篇文章 0 订阅

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

    题意:在程序设计比赛中有T个队,M道题,冠军最少要对N道题,输入i队完成第j道题的概率,最后得到所有队至少完成1道题且有冠军产生的概率。

    思路:该题为概率+DP,解题关键就在于找到每队完成K题(1<=K<=M)的概率,即找到该状态转移方程。不多说废话,本人也是参考的其他人的推导方法。

  

       下面是本人按照上图的思路写的代码,思路很好理解,一次AC。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007

using namespace std;

double dp[1005][31][31];
double p[1005][31],s[1005][31];
int m,t,n;
void Clear()
{
    int i,j;
    memset(s,0,sizeof(s));
    memset(dp,0,sizeof(dp));
    for (i=1;i<=t;i++)
    {
        dp[i][0][0]=1.0;
    }
    for (i=1;i<=t;i++)
    {
        for (j=1;j<=m;j++)
        {
            dp[i][j][0] = dp[i][j-1][0]*(1-p[i][j]);
        }
    }
}
int main()
{
    int i,j,k;
    while(scanf("%d%d%d",&m,&t,&n),n||m||t)
    {
        for (i=1;i<=t;i++)
        {
            for (j=1;j<=m;j++)
            {
                scanf("%lf",&p[i][j]);
            }
        }
        Clear();
        for (i=1;i<=t;i++)
        {
            for (j=1;j<=m;j++)
            {
                for (k=1;k<=m;k++)
                {
                    dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
                }
            }
        }
        for (i=1;i<=t;i++)
        {
            for (k=1;k<=m;k++)
            {
                s[i][k]=s[i][k-1]+dp[i][m][k];
            }
        }
        double p1=1,p2=1;
        for (i=1;i<=t;i++)
        {
            p1 *= s[i][m]-s[i][0];
            p2 *= s[i][n-1]-s[i][0];
        }
        printf("%.3lf\n",p1-p2);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
POJ - 3616是一个题目,题目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问题的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值