POJ 3784 Running Median

Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input
3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56

Sample Output
1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3

【分析】
二叉堆维护
分别维护一个大根堆和一个小根堆。
操作:如果比当前中位数k大的话那么进小根堆,反之进大根堆
维护:小根堆元素比大根堆元素多一个
具体做法:两个两个的加元素
用到了C++的STL,很省代码长度

【代码】

//poj 3784 Running Median
#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
priority_queue <int> da;
priority_queue < int,vector<int>,greater<int> > xiao;
int Q,n,x,y,t;
int a[5001];
bool b;
int main()
{
    int i,j,k,p,f,d;   //k为中位数 
    scanf("%d",&Q);
    while(Q--)
    {
        t=0;b=0;
        scanf("%d%d%d",&d,&n,&x);
        if(n%2==0) b=1;
        k=x;
        a[++t]=k;
        xiao.push(k);
        fo(i,1,(n-1)/2)
        {
            scanf("%d%d",&x,&y);
            if(x>=k) xiao.push(x);
            else da.push(x);
            if(y>=k) xiao.push(y);
            else da.push(y);
            while(xiao.size()!=da.size()+1 && xiao.size()>da.size()) 
            //如果小根堆大 
            {
                p=xiao.top();
                xiao.pop();
                da.push(p); 
            }
            while(xiao.size()!=da.size()+1 && da.size()>xiao.size())
            //如果大根堆大 
            {
                p=da.top();
                da.pop();
                xiao.push(p); 
            }
            k=xiao.top();
            a[++t]=k;
        }
        if(b) scanf("%d",&x);
        printf("%d %d\n",d,(n+1)>>1);
        fo(i,1,t)
        {
            printf("%d ",a[i]);
            if(i%10==0) printf("\n");
        }
        printf("\n");
        while(!xiao.empty()) xiao.pop();
        while(!da.empty()) da.pop();
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,这是一个关于二叉树遍历的问题。具体来说,给定二叉树的前序遍历和中序遍历,需要求出二叉树的后序遍历。 以下是一个Java实现的例子: ```java import java.util.Scanner; class Node { char value; Node left; Node right; public Node(char value) { this.value = value; } } public class Main { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); int t = scanner.nextInt(); while (t-- > 0) { int n = scanner.nextInt(); String preOrder = scanner.next(); String inOrder = scanner.next(); Node root = buildTree(preOrder, inOrder); postOrder(root); System.out.println(); } scanner.close(); } private static Node buildTree(String preOrder, String inOrder) { if (preOrder.length() == 0) { return null; } char rootValue = preOrder.charAt(0); int rootIndex = inOrder.indexOf(rootValue); Node root = new Node(rootValue); root.left = buildTree(preOrder.substring(1, rootIndex + 1), inOrder.substring(0, rootIndex)); root.right = buildTree(preOrder.substring(rootIndex + 1), inOrder.substring(rootIndex + 1)); return root; } private static void postOrder(Node root) { if (root == null) { return; } postOrder(root.left); postOrder(root.right); System.out.print(root.value); } } ``` 这段代码首先读取输入的测试用例数量t,然后依次读取每个测试用例的节点数量n、前序遍历和中序遍历的字符串。接下来,通过递归构建二叉树,并使用后序遍历输出结果。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值