poj 3278 Catch That Cow

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 74854 Accepted: 23630

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4


【分析】
最近迷之懒惰,不想更博,然而考虑到老师可能会查我水表,还是先写上两篇。
题意:男主起初在n点,每步可以走前一个位置,后一个位置,或者二倍的位置,问最少几步能到达指定点。
那就宽搜一下出解(标记过的点就不走了,别人说要剪枝什么的其实不用),复杂度   O(n)
see you


【代码】

//poj 3278 Catch That Cow
#include<iostream>
#include<cstdio>
#include<cstring>
#define fo(i,j,k) for(i=j;i<=k;i++)
#define M(a) memset(a,0,sizeof a)
using namespace std;
int n,m;
int q[200001],map[200001];
bool vis[200001];
int main()
{
    int i,j,k,u,v;
    scanf("%d%d",&n,&m);
    if(n>m) printf("%d\n",n-m);
    int h=0,t=1;
    q[t]=n;
    vis[n]=1;
    while(h<t)
    {
        h++;
        u=q[h];
        v=u-1;
        if(v>=0 && v<=m+5 && !vis[v])
        {
            vis[v]=1;
            q[++t]=v;
            map[v]=map[u]+1;
        }
        v=u+1;
        if(v>=0 && v<=m+5 && !vis[v])
        {
            vis[v]=1;
            q[++t]=v;
            map[v]=map[u]+1;
        }
        v=u+u;
        if(v>=0 && v<=m+5 && !vis[v])
        {
            vis[v]=1;
            q[++t]=v;
            map[v]=map[u]+1;
        }
        if(vis[m]) {printf("%d\n",map[m]);return 0;}
    }
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值