poj 3687 Labeling Balls

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:
1.No two balls share the same label.
2.The labeling satisfies several constrains like “The ball labeled with a is lighter than the one labeled with b”.

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls’ weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on… If no solution exists, output -1 instead.

Sample Input
5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4


【分析】
这道题在我经过百度翻译的帮助下似乎是看懂了,我天真的认为丫就是拓扑排序+字典序较小方案,结果WA死了。

15913751 chaijing 3687 Wrong Answer G++ 770B 2016-08-07 20:54:18
15913743 chaijing 3687 Wrong Answer G++ 770B 2016-08-07 20:52:38
15909802 chaijing 3687 Wrong Answer G++ 1875B 2016-08-06 22:02:27

各种花式解题均以失败告终,于是——看题解。
结果题意是要让逆序建图啊。。(并不知道为什么)
而且输出并不是字典序最小,而是各个节点的拓扑序标号依次输出
总之坑点满满。
所以什么是逆向建图呢,就是从拓扑序列较大的号往拓扑序列较小的号一步一步推,推上n次就出解了。


【代码】

//poj 3687 Labeling Balls
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#define fo(i,j,k) for(int i=j;i<=k;i++)
#define M(a) memset(a,0,sizeof a)
using namespace std;
bool g[201][201],vis[201];
int in[201],ans[201];
int T,n,m,x,y;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        bool flag=0;
        M(g);M(in);M(vis);
        scanf("%d%d",&n,&m);
        while(m--)
        {
            scanf("%d%d",&x,&y);
            if(!g[y][x])
              g[y][x]=1,in[x]++;
        }
        for(int i=n;i>=1;i--)
        {
            int q=0;
            for(int j=n;j>=1;j--)
              if(!vis[j] && !in[j])
              {
                q=j;break;
              }
            if(!q) {printf("-1");flag=1;break;}
            vis[q]=1;
            ans[q]=i;
            fo(j,1,n)
              if(g[q][j])
                in[j]--;
        }
        if(!flag)
          fo(i,1,n)
            printf("%d ",ans[i]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值