poj 3694 Network

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output
Case 1:
1
0

Case 2:
2
0


【分析】
tarjan求桥+lca
利用dfn的神奇性质
握了个大草,这道题好像忽略重边的样子
我判了重边一直WA,不判就A了…迷丫


【代码】

//poj 3694 Network
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int mxn=100005;
int n,m,q,cnt,tim,ans;
int head[mxn],dfn[mxn],low[mxn],father[mxn],baba[mxn];
struct edge {int to,next;} f[mxn*5];
inline void add(int u,int v)
{
    f[++cnt].to=v,f[cnt].next=head[u],head[u]=cnt;
}
inline int find(int x)
{
    if(x!=father[x]) father[x]=find(father[x]);
    return father[x];
}
inline void tarjan(int u,int fa)
{
    int i,j,v,flag=0;
    dfn[u]=low[u]=++tim;
    for(i=head[u];i;i=f[i].next)
    {
        v=f[i].to;
        if(!dfn[v])
        {
            baba[v]=u;
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(dfn[u]<low[v]) ans++;
            else father[find(v)]=find(u);
        }
        else if(v!=fa)
          low[u]=min(low[u],dfn[v]);
    }
}
inline int lca(int x,int y)
{
    if(dfn[x]<dfn[y]) swap(x,y);  //x更深 
    while(dfn[x]>dfn[y])
    {
        if(find(x)!=find(baba[x]))
          ans--,father[find(x)]=find(baba[x]);
        x=baba[x];
    }
    while(y!=x)
    {
        if(find(y)!=find(baba[y]))
          ans--,father[find(y)]=find(baba[y]);
        y=baba[y];
    }
    return ans;
}
int main()
{
    int i,j,u,v,T=0;
    while(scanf("%d%d",&n,&m) && n && m)
    {
        printf("Case %d:\n",++T);
        cnt=tim=ans=0;
        M(head);M(baba);M(dfn);M(low);
        fo(i,1,n) father[i]=i;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            add(u,v),add(v,u);
        }
        tarjan(1,0);
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d",&u,&v);
            printf("%d\n",lca(u,v));
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值