poj 2892 Tunnel Warfare

Tunnel Warfare
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 8340 Accepted: 3442
Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!

Input

The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.
Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.
R: The village destroyed last was rebuilt.
Output

Output the answer to each of the Army commanders’ request in order on a separate line.

Sample Input

7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4
Sample Output

1
0
2
4
Hint

An illustration of the sample input:

  OOOOOOO

D 3 OOXOOOO

D 6 OOXOOXO

D 5 OOXOXXO

R OOXOOXO

R OOXOOOO
Source

POJ Monthly–2006.07.30, updog


【分析】
STL大法好,set把你保,写什么平衡树,作死的节奏


【代码】

//POJ 2892 Tunnel Warfare
#include<iostream>
#include<cstring>
#include<cstdio>
#include<set> 
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int mxn=50005;
int n,m,num;
int czy[mxn];
bool des[mxn];
set <int> tree;
int main()
{
    int i,j,x,mx,mn;
    char c[3];
    scanf("%d%d",&n,&m);
    tree.insert(0),tree.insert(n+1);
    while(m--)
    {
        scanf("%s",c);
        if(c[0]=='D')
        {
            scanf("%d",&x);
            tree.insert(x);
            des[x]=1;
            czy[++num]=x;
        }
        else if(c[0]=='Q')
        {
            scanf("%d",&x);
            if(des[x]) printf("0\n");
            else 
            {
                set<int>::iterator tmp;
                tmp=tree.lower_bound(x);
                int next=*tmp;tmp--;
                int pre=*tmp;
                printf("%d\n",next-pre-1);
            }
        }
        else tree.erase(czy[num]),des[czy[num]]=0,num--;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值