Cellular Automaton
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 3665 Accepted: 1491
Case Time Limit: 2000MS
Description
A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.
The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.
One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.
A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.
On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.
The following picture shows 1-step of the 5,3-automaton.
The problem is to calculate the state of the n,m-automaton after k d-steps.
Input
The first line of the input file contains four integer numbers n, m, d, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n⁄2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.
Output
Output the values of the n,m-automaton’s cells after k d-steps.
Sample Input
sample input #1
5 3 1 1
1 2 2 1 2
sample input #2
5 3 1 10
1 2 2 1 2
Sample Output
sample output #1
2 2 2 2 1
sample output #2
2 0 0 2 2
Source
【分析】
我有一句mmp要讲…取模要取好
http://hzwer.com/1817.html
注意题解里的一句话有问题
所以最终结果就是:a * (b^k)
应改为 b * (a^k)
所以说写题解也要走心啊…
【代码】
#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(int i=j;i<=k;i++)
using namespace std;
const int mxn=505;
ll n,m,d,mod;
struct matrix
{
ll a[mxn];
matrix operator * (const matrix &x) const
{
matrix res;
fo(i,1,n)
{
res.a[i]=0;
fo(k,1,n)
{
if(i-k+1>=1) res.a[i]=(res.a[i]+a[k]*x.a[i-k+1])%mod;
else res.a[i]=(res.a[i]+a[k]*x.a[i-k+1+n])%mod;
}
}
return res;
}
}ans,a,x;
int main()
{
scanf("%lld%lld%lld%lld",&n,&mod,&d,&m);
fo(i,1,n) scanf("%lld",&ans.a[i]); //快速幂矩阵x ,原矩阵ans
fo(i,1,d+1) x.a[i]=1;
fo(i,n-d+1,n) x.a[i]=1;
while(m)
{
while((m&1)==0) m>>=1,x=x*x;
ans=ans*x;
m>>=1,x=x*x;
}
fo(i,1,n) printf("%lld ",ans.a[i]);
cout<<endl;
return 0;
}