poj 3130 How I Mathematician Wonder What You Are!

How I Mathematician Wonder What You Are!
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3773 Accepted: 2025

Description

After counting so many stars in the sky in his childhood, Isaac, now an astronomer and a mathematician uses a big astronomical telescope and lets his image processing program count stars. The hardest part of the program is to judge if shining object in the sky is really a star. As a mathematician, the only way he knows is to apply a mathematical definition of stars.

The mathematical definition of a star shape is as follows: A planar shape F is star-shaped if and only if there is a point C ∈ F such that, for any point P ∈ F, the line segment CP is contained in F. Such a point C is called a center of F. To get accustomed to the definition let’s see some examples below.

The first two are what you would normally call stars. According to the above definition, however, all shapes in the first row are star-shaped. The two in the second row are not. For each star shape, a center is indicated with a dot. Note that a star shape in general has infinitely many centers. Fore Example, for the third quadrangular shape, all points in it are centers.

Your job is to write a program that tells whether a given polygonal shape is star-shaped or not.

Input

The input is a sequence of datasets followed by a line containing a single zero. Each dataset specifies a polygon, and is formatted as follows.

n 
x1y1
x2y2

xnyn

The first line is the number of vertices, n, which satisfies 4 ≤ n ≤ 50. Subsequent n lines are the x- and y-coordinates of the n vertices. They are integers and satisfy 0 ≤ xi ≤ 10000 and 0 ≤ yi ≤ 10000 (i = 1, …, n). Line segments (xiyi)–(xi + 1yi + 1) (i = 1, …, n − 1) and the line segment (xnyn)–(x1y1) form the border of the polygon in the counterclockwise order. That is, these line segments see the inside of the polygon in the left of their directions.

You may assume that the polygon is simple, that is, its border never crosses or touches itself. You may assume assume that no three edges of the polygon meet at a single point even when they are infinitely extended.

Output

For each dataset, output “1” if the polygon is star-shaped and “0” otherwise. Each number must be in a separate line and the line should not contain any other characters.

Sample Input

6 
66 13 
96 61 
76 98 
13 94 
4 0 
45 68 
8 
27 21 
55 14 
93 12 
56 95 
15 48 
38 46 
51 65 
64 31 
0

Sample Output

1
0

Source

Japan 2006





【分析】

半平面交第一题...O(nlogn)

貌似是先极角排序,然后斜率相同的点用叉积判一下取靠左边的直线。

然后一个一个扔到双端队列,如果新加入的直线被原来的某条直线构成的半平面覆盖掉,那么把某直线弹出队列。

最后YY一下,半平面交是一个凸包?队列里的元素个数k即代表凸包是k边形。

如果k>=3那么ans=true。



【代码】

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const double eps=1e-8;
const int mxn=55;
int h,t,pn,ln,n;
int order[mxn],deque[mxn];
struct point {double x,y;} p[mxn];
struct line {point a,b;double ang;} l[mxn];
inline int dbcomp(double k) 
{
	if(fabs(k)<eps) return 0;
	return k>0?1:-1;
}
inline double mul(point p0,point p1,point p2)
{
	return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}
inline bool comp(int u,int v)
{
	int d=dbcomp(l[u].ang-l[v].ang);
	if(!d) return dbcomp(mul(l[u].a,l[v].a,l[v].b))>0;
	return d<0;
}
inline void addline(double x1,double y1,double x2,double y2)
{
	l[ln].a.x=x1,l[ln].a.y=y1;
	l[ln].b.x=x2,l[ln].b.y=y2;
	l[ln].ang=atan2(y2-y1,x2-x1);
	order[ln]=ln,ln++;
}
inline void get(line l1,line l2,point &p)
{
	double d1,d2;
	d1=mul(l2.a,l1.b,l1.a);
	d2=mul(l1.b,l2.b,l1.a);
	p.x=(l2.a.x*d2+l2.b.x*d1)/(d1+d2);
	p.y=(l2.a.y*d2+l2.b.y*d1)/(d1+d2);
}
inline bool judge(line l0,line l1,line l2)
{
	point p;
	get(l1,l2,p);
	return dbcomp(mul(p,l0.a,l0.b))<0;
}
inline void HPI()
{
	int i,j;
	sort(order,order+ln,comp);
	for(i=1,j=0;i<ln;i++)
	  if(dbcomp(l[order[i]].ang-l[order[j]].ang)>0)
	    order[++j]=order[i];
	ln=j+1;
	deque[0]=order[0];
	deque[1]=order[1];
	h=0,t=1;
	for(i=2;i<ln;i++)
	{
		while(h<t && judge(l[order[i]],l[deque[t-1]],l[deque[t]])) t--;
		while(h<t && judge(l[order[i]],l[deque[h+1]],l[deque[h]])) h++;
		deque[++t]=order[i];
	}
	while(h<t && judge(l[order[h]],l[deque[t-1]],l[deque[t]])) t--;
	while(h<t && judge(l[order[t]],l[deque[h+1]],l[deque[h]])) h++;
}
int main()
{
	int i,j;
	while(scanf("%d",&n) && n)
	{
		fo(i,0,n-1)
		  scanf("%lf%lf",&p[i].x,&p[i].y);
		for(ln=i=0;i<n-1;i++)
		  addline(p[i].x,p[i].y,p[i+1].x,p[i+1].y);
		addline(p[i].x,p[i].y,p[0].x,p[0].y);
		HPI();
		if(t-h>1) printf("1\n");
		else printf("0\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值