poj 2356 Find a multiple (鸽巢原理妙用)

题目链接:http://poj.org/problem?id=2356

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

【题目大意】

首先输入一个n,然后给你n个数,让你从中找到 m个数, 1<=m<=n,使得这m个数的和是n的倍数;如果找不到输出0;

【分析】

我们先用一个sum数组,将a【0】, a【0】+a【1】,a【0】+a【1】+a【2】......储存起来;

然后判断这些数能否整除n,如果能则输出下标,然后直接从第一个数开始依次输出即可(题目是special judge,只要找到即可,而且顺序也是in arbitrary order.)

然后,关键的地方来了,因为sum[I]%n一定是属于【1~n-1】的,而sum总共有n个,根据鸽巢定理

把多于n个的物体放到n个抽屉里,则至少有一个抽屉里有2个或2个以上的物体。
所以n个 sum【i】%n中,至少有两个是一样的;(因此,此题一定有解,不存在输出0的情况)

如果我们找到,则说明(sum[j]-sum[i])%n==0  (假设一个是sum【i】,一个是sum【j】,j>i,

也就是 加在 i j 之间的数的和是 n的倍数,只要依次将他们输出就可以了。

【代码如下】

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 10010;
int num[maxn];
int mod[maxn];
int sum[maxn];
int main()
{
	int n;
	cin>>n;
	memset(mod, -1 ,sizeof(mod));
	for(int i=0;i<n;i++)
	{
		cin>>num[i];
		if(i>0)
			sum[i]=sum[i-1]+num[i];
		else
			sum[i]=num[i];
	}
	int sign=0;
	for(int i=0;i<n;i++)
	{
		if(sum[i]%n==0)
		{
			sign=1;
			cout<<i+1<<endl;
			for(int j=0;j<=i;j++)
				cout<<num[j]<<endl;
			break;
		}
		if(mod[sum[i]%n]!=-1)//如果被赋值过了,则说明遇到相同的余数了;
		{
			int tm=i-mod[sum[i]%n];
			cout<<tm<<endl;
			for(int j=mod[sum[i]%n]+1;j<=i;j++)
				cout<<num[j]<<endl;
			break;
		}
		mod[sum[i]%n]=i;//将取余的数保存起来
	}
	return 0;
}
也是参考了,博主的代码和思路 大神博客 ,代码中值得注意的技巧是用mod数组来储存余数。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值