题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=1312
Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 13080 Accepted Submission(s): 8109
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
题目很简单,注意W和H别搞混了就行,仔细看题
【源代码】
#include<iostream>
#include<cstring>
using namespace std;
int n,m;
char map[25][25];
bool vis[25][25];
int stx,sty,cnt;
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
bool judge(int x,int y){//将判断条件抽取
if(x<0||x>=n||y<0||y>=m||vis[x][y]||map[x][y]=='#')
return false;
return true;
}
void dfs(int x,int y){
for(int i=0;i<4;i++){
int next_x=x+dx[i];
int next_y=y+dy[i];
if(!judge(next_x,next_y)) continue;
vis[next_x][next_y]=true;
cnt++;
// cout<<next_x<<" "<<next_y<<endl;
dfs(next_x,next_y);
}
}
int main(){
while(cin>>m>>n&&(n||m)){
for(int i=0;i<n;i++)
for(int j=0;j<m;j++){
cin>>map[i][j];
if(map[i][j]=='@')
{stx=i;sty=j;}
}
cnt=1;
memset(vis,0,sizeof(vis));
vis[stx][sty]=true;
dfs(stx,sty);
cout<<cnt<<endl;
}
return 0;
}