Cow Contest
-
描述
-
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
-
输入
-
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
There are multi test cases.The input is terminated by two zeros.The number of test cases is no more than 20.
输出
-
For every case:
* Line 1: A single integer representing the number of cows whose ranks can be determined
样例输入
-
5 5 4 3 4 2 3 2 1 2 2 5 0 0
样例输出
-
2
-
* Line 1: Two space-separated integers: N and M
题目大意:有n头牛比赛,m种比赛结果,最后问你一共有多少头牛的排名被确定了,其中如果a战胜b,b战胜c,则也可以说a战胜c,即可以传递胜负。求能确定排名的牛的数目。
关键在于传递胜负。 想到了这一点就不难想到可以完成传递闭包的Floyd算法。
只要满足大于 当前节点 的牛的数量 加上 小于当前节点牛的数量等于 n - 1, 那么当前节点的排名(rank)就可以确定了
上面的条件只要相通,就非常容易编程了。然而笔者并没有想到。。
【CODE】
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
int map[111][111];
int main(){
int n,m;
while(scanf("%d%d",&n,&m)!=EOF && (n||m)){
int a,b;
memset(map,0,sizeof(map));
for(int i=0;i<m;i++){
scanf("%d%d",&a,&b);
map[a-1][b-1] = 1;
}
for(int k=0;k<n;k++) //传递闭包
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(map[i][k] && map[k][j]) //传递
map[i][j] = 1;
int ans =0;
for(int i=0;i<n;i++){
int l = 0; // 出度入度的和,也就是大于他,小于他的节点的总数
for(int j=0;j<n;j++){
if(map[i][j] || map[j][i])
l++;
}
if(l == n-1)
ans++;
}
printf("%d\n",ans);
}
return 0;
}