从shape类扩展出一个正五边形类(求五边形的面积和周长)----java

从下列的shape类扩展出一个正五边形(regular pentagon)类RPentagon,这个类将正五边形的边长作为私有成员,类中包含初始化这个值的构造方法。

class shape {// 形状类

  // 求面积
  public double getArea() {
   return 0;
  }

 // 求周长
  public double getPerimeter() {
    return 0;
  }
}

计算正五边形的面积公式为: S=a
​2
​​ ×√
​25+10×√
​5

​​

正五边形类名:
RPentagon
裁判测试程序样例:
import java.util.Scanner;
import java.text.DecimalFormat;

class shape {// 形状类

  // 求面积
  public double getArea() {
    return 0;
  }

  // 求周长
  public double getPerimeter() {
    return 0;
  }
}

/* 你提交的代码将被嵌入到这里 */

public class Main {
public static void main(String[] args) {
    Scanner input = new Scanner(System.in);
    DecimalFormat d = new DecimalFormat("#.####");// 保留4位小数
    double side = input.nextDouble();

    shape rp = new RPentagon(side);

    System.out.println(d.format(rp.getArea()));
    System.out.println(d.format(rp.getPerimeter()));
    input.close();
 } 
}

输入样例:
16.8
输出样例:
485.5875
84

解答:

class RPentagon extends shape {

  RPentagon(double side) {
    a = side;
  }
  @Override
  public double getArea() {
    return 0.25 * a * a * Math.sqrt(25 + 10 * Math.sqrt(5));
  }
  @Override
  public double getPerimeter() {
    return 5 * a;
  }
  private double a;
}

补全代码:

package com.xupt.java.demo;

import java.util.Scanner;
import java.text.DecimalFormat;

class shape {// 形状类

  // 求面积
  public double getArea() {
    return 0;
  }

  // 求周长
  public double getPerimeter() {
    return 0;
  }
}

/* 你提交的代码将被嵌入到这里 */
class RPentagon extends shape {

  RPentagon(double side) {
    a = side;
  }
  @Override
  public double getArea() {
    return 0.25 * a * a * Math.sqrt(25 + 10 * Math.sqrt(5));
  }
  @Override
  public double getPerimeter() {
    return 5 * a;
  }
  private double a;
}

public class Main {
  public static void main(String[] args) {
    Scanner input = new Scanner(System.in);
    DecimalFormat d = new DecimalFormat("#.####");// 保留4位小数
    double side = input.nextDouble();
    shape rp = new RPentagon(side);
    System.out.println(d.format(rp.getArea()));
    System.out.println(d.format(rp.getPerimeter()));
    input.close();
  }
}

  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值