HDU1098 Ignatius's puzzle 【数论】

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6559    Accepted Submission(s): 4540


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43
 

Author
eddy

题意:求出使x为任意值时f(x)都能被65整除的最小a的值,若不存在输出no。

题解:若任意f(x)都能被65整除,那么f(1)%65==0,(f(x+1)-f(x))%65 == 0,二项式展开得(18+k*a)%65 == 0,所以只需要遍历找到a即可。

#include <stdio.h>

int main() {
	int k, a;
	while(~scanf("%d", &k)) {
		for(a = 0; a <= 65; ++a)
			if((18 + k*a) % 65 == 0) {
				printf("%d\n", a);
				break;
			}
		if(a > 65) printf("no\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值