PAT甲级 1020. Tree Traversals (25)

题目:

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

思路:

1.根据后序和中序的序列构建二叉树

2.利用广度优先搜索

注意:

曾经利用深度优先搜索来做,但第五个测试点出现段错误,说明应采用广度优先搜索


代码:

#include<iostream>
#include<vector>
using namespace std;

#ifndef Maxnum
#define Maxnum 31

struct node
{
	int left;
	int right;
};

node tree[Maxnum];
int postor[Maxnum];
int inor[Maxnum];
//构建二叉树
int creattree(int post_be,int post_end,int in_be,int in_end)
{
	if(post_be<post_end)
	{
		int root=postor[post_end];
		int i;
		for(i=0;i<Maxnum;++i)
		{
			if(inor[i]==root)
			   break;
		}
		int len,left,right;
		//左子树
		len=i-in_be;
		tree[root].left=creattree(post_be,post_be+len-1,in_be,i-1);
		//右子树
		len=in_end-i;
		tree[root].right=creattree(post_end-len,post_end-1,i+1,in_end);
		return root;
	}
	else if(post_be==post_end)
	{
		return postor[post_end];
	}
	else
		return 0;
}

//广度优先搜索
vector<int> q;
vector<int> q1;
void bfs(int root)
{
	if(root!=0)
	{
		q1.push_back(root);//插入根节点
		q.push_back(root);
		while(!q1.empty())
		{
			int p=q1.front();
			q1.erase(q1.begin());
			if(tree[p].left!=0)
			{
				q1.push_back(tree[p].left);
				q.push_back(tree[p].left);
			}
			if(tree[p].right!=0)
			{
				q1.push_back(tree[p].right);
				q.push_back(tree[p].right);
			}
		}
	}
}
int main()
{
	int N;
	cin>>N;
	int i;
	for(i=0;i<N;++i)
	{
		cin>>postor[i];
	}
	for(i=0;i<N;++i)
	{
		cin>>inor[i];
	}

	int root;
	root=creattree(0,N-1,0,N-1);
	//广度优先搜索
	bfs(root);
	for(i=0;i<N;++i)
	{
		cout<<q[i];
		if(i!=N-1)
			cout<<" ";
		else
			cout<<endl;
	}
	system("pause");
	return 0;
}
#endif


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值