1020 Tree Traversals (25 分)(C语言实现)(PAT)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
算法&程序
#include <stdlib.h>
#include <stdio.h>
#define MaxTreeNode 30
struct TNode{
    int left, right;
}Tree[MaxTreeNode];

typedef struct QueueNode *Queue;
struct QueueNode{
    int data[MaxTreeNode], front, rear;
};
int postorder[MaxTreeNode], inorder[MaxTreeNode];
void push(int X, Queue Q)
{
    Q->data[Q->rear++] = X;
}
int pop(Queue Q)
{
    return Q->data[Q->front++];
}
int CreatTree(int lmid, int rmid, int lpost, int rpost)
{
    if(lmid > rmid || lpost > rpost) return -1;
    int aim = postorder[rpost];
    int num = lmid;
    while (inorder[num] != aim) num++;
    int len = num - lmid;
    Tree[aim].left = CreatTree(lmid, num-1, lpost, lpost+len-1);
    Tree[aim].right = CreatTree(num+1, rmid, lpost+len, rpost-1);
    return aim;
}


int main()
{
    int N,cnt=0;
    scanf("%d", &N);

    for(int i = 0; i < N; i++ ) scanf("%d", &postorder[i]);
    for(int i = 0; i < N; i++ ) scanf("%d", &inorder[i]);


    Queue Q;
    Q = (Queue)malloc(sizeof(struct QueueNode));
    Q->front = Q->rear = 0;

    for(int i = 0; i < N; i++ ) Tree[i].left = Tree[i].right = -1;
    CreatTree(0, N-1, 0, N-1);
    int root = postorder[N-1];

    push(root, Q);
    while(Q->front != Q->rear){
        int temp = pop(Q);
        if(++cnt != N) printf("%d ", temp);
        else printf("%d\n", temp);
        if(Tree[temp].left != -1) push(Tree[temp].left,Q);
        if(Tree[temp].right != -1) push(Tree[temp].right,Q);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值