PAT甲级 1031. Hello World for U (20)

题目:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1  characters, then left to right along the bottom line with n 2  characters, and finally bottom-up along the vertical line with n 3  characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1  = n 3  = max { k| k <= n 2  for all 3 <= n 2  <= N } with n 1  + n 2  + n 3  - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor
思路:

这道题属于运筹学的内容,有段时间没接触了,所以这里用了略笨的方法。

1.先根据3 <= n2 <= N 的条件,遍历n2;

2.再根据n1 + n2 + n3 - 2 = N和n1 = n3 找到符合条件的值;

3.最后再根据条件k <= n2和要求max { k| k <= n2 for all 3 <= n2 <= N } 筛选得到相应的n1,n2和n3.

得到相应的值后,再进行输出。这里还要注意的是处最后一行外,每一行都需要根据n2的值在字符之间输出n2-2个空格。

代码:

#include<iostream>
#include<string>
using namespace std;

int main()
{
	
	string S;
	cin >> S;
	int i;
	int n1, n2, n3;
	int k,N;
	n1 = 0;
	N = S.size();
	for (n2 = 3; n2 <= N; ++n2)
	{
		if (!((N + 2 - n2) % 2)) //判断是否有符合等式限制条件的存在
		{
			k = (N + 2 - n2) / 2;
			if (k <= n2 && k > n1)//判断当前k是否满足条件且为最新找到的最大值
				n1 = k;
		}	
	}
	n3 = n1;
	n2 = N + 2 - n1 - n3;
	//output
	int j;
	for (i = 0; i < n1-1; ++i)
	{
		cout << S[i];
		for (j = 0; j < n2 - 2; ++j)
			cout << " ";
		cout << S[N - 1 - i] << endl;
	}
	for (i = 0; i < n2; ++i)
	{
		cout << S[n1 -1+ i];
	}
	cout << endl;

	
	system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值