1031. Hello World for U (20)-PAT甲级真题

1031. Hello World for U (20)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible — that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!

Sample Output:
h     !
e    d
l      l
 lowor


分析:这道题就是把一个字符串编程U型输出,n1,n3就是左右两边竖着的,这两个值相等,n2就是U型底部的,要大于n1,n2。
  既然这样的话,就先把整个字符串平均分成3部分。因为要求n2>=n1,n1还要尽可能大,也就是n%3这多出来的不能给侧面,只可能给n2,所以。
  n1=n/3,n2=n/3+n%3

#include <cstdio>
#include <string.h>
using namespace std;
int main() {
    char c[81];
    char u[30][30];
    memset(u, ' ', sizeof(u));
    scanf("%s", c);
    int n = strlen(c) + 2;
    int n1 = n / 3;
    int n2 = n1 + n % 3;
    int index = 0;
    for(int i = 0; i < n1; i++) {
        u[i][0] = c[index++];
    }
    for(int i = 1; i <= n2 - 2; i++) {
        u[n1-1][i] = c[index++];
    }
    for(int i = n1 - 1; i >= 0; i--) {
        u[i][n2-1] = c[index++];
    }
    for(int i = 0; i < n1; i++) {
        for(int j = 0; j < n2; j++) {
            printf("%c", u[i][j]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值