POJ2251-Dungeon Master(BFS)

                             Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 57669 Accepted: 21275

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

大概意思:

假设你被困在了一个3D地牢里,你要以最短的路径逃出去。你可以向着 东、西、南、北、上、下、进行移动,但不能斜着移动。

输入:

           L, R and C 分别代表层数,行数,列数
           然后输入每一层的具体构造,'#'代表石块,'.'代表空白(可通行),S代表开始的地方,E代表逃出去的地方。

输出:

成功逃出去打印出:Escaped in x minute(s).          x代表x步

失败打印:                Trapped!

代码实现

#include<iostream>
#include<queue>
using namespace std;

#define MAX 40

bool map[MAX][MAX][MAX];	//标志地牢的结构,true代表可通行,false是有障碍
bool flag[MAX][MAX][MAX];	//标志是否走过
int layer, row, column;
int sl, sr, sc, el, er, ec;	//开始的层数、行、列;以及结束的层数、行、列
int moveTo[6][3] = { { 0, 0, 1 }, { 0, 0, -1 }, { 0, 1, 0 }, { 0, -1, 0 }, { 1, 0, 0 }, { -1, 0, 0 } };	//东西南北上下

struct Node{
	int l, r, c, step;
};

int bfs()
{
	Node a, nextStep;
	queue<Node> Q;
	a.l = sl;
	a.r = sr;
	a.c = sc;
	a.step = 0;
	flag[a.l][a.r][a.c] = true;
	Q.push(a);	//把开始的位置加入到队列
	while (!Q.empty())
	{
		a = Q.front();	//取队首
		Q.pop();		//弹出来
		if (a.l == el && a.r == er && a.c == ec)	//找到出口
		{
			return a.step;
		}
		for (int i = 0; i < 6; i++)
		{
			nextStep = a;
			nextStep.l = a.l + moveTo[i][0];
			nextStep.r = a.r + moveTo[i][1];
			nextStep.c = a.c + moveTo[i][2];
			//判断边界,地图结构,是否走过(走过则跳过此次循环)
			if (nextStep.l < 0 || nextStep.l >= layer || nextStep.r < 0 || nextStep.r >= row || nextStep.c < 0 || nextStep.c >= column ||
				!map[nextStep.l][nextStep.r][nextStep.c] || flag[nextStep.l][nextStep.r][nextStep.c])
			{
				continue;	//跳过
			}
			flag[nextStep.l][nextStep.r][nextStep.c] = true;
			nextStep.step = a.step + 1;	//继承上面的步数
			Q.push(nextStep);	//push操作做到了先把临近的点放到队首的作用,每一次pop的时候相当于先找临近点,即兄弟节点
		}
	}
	return 0;
}



int main()
{
	while (1)
	{
		cin >> layer >> row >> column;
		if (layer == 0 && row == 0 && column == 0)
			break;
		memset(flag, false, sizeof(flag));	//重置
		memset(map, false, sizeof(map));	//重置,一定要重置,不然会有错,因为下面switch语句没有设置'#'的情况
		for (int i = 0; i < layer; i++)
		{
			for (int j = 0; j < row; j++)
			{
				for (int k = 0; k < column; k++)
				{
					char temp;
					cin >> temp;
					switch (temp)
					{
						case 'S':
							map[i][j][k] = true;
							sl = i;
							sr = j;
							sc = k;
							break;
						case 'E':
							map[i][j][k] = true;
							el = i;
							er = j;
							ec = k;
							break;
						case '.':
							map[i][j][k] = true;
							break;
					}
				}
			}
		}
		int minutes;
		minutes = bfs();
		if (minutes)
			cout << "Escaped in " << minutes << " minute(s)."<<endl;	//最后的换行要加上
		else
			cout << "Trapped!"<<endl;
	}
	return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值