nyoj-103 A+B Problem II

描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation.

样例输入

2
1 2
112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;

int main()
{
    int n;
    cin>>n;
    int k=1;
    while (n--)
    {
        char a[1000],b[1000];
        int c[1001]={0},d[1001]={0};
        int e[1001]={0};
        int n1,n2;
        int i,j,z=0;
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        cin>>a>>b;
        n1 = strlen(a);
        n2 = strlen(b);
        int q = n1>n2?n1:n2;
        for (i=0,j=n1-1;i<n1;++i,j--)
        {
            c[i] = a[j]-'0';
        }
        for (i=0,j=n2-1;i<n2;++i,j--)
        {
            d[i] = b[j]-'0';
             //printf ("%d",d[i]);
        }
        for (i=0;i<q;i++)
        {
            e[i]=c[i]+d[i];
        }
        for (i=0;i<q;i++)
        {
            if (e[i]>=10)
            {
                e[i]-=10;
                e[i+1]++;
            }
        }
        printf ("Case %d:\n",k);
        printf ("%s + %s = ",a,b);
        for (i=1000;i>=0;i--)
        {
            if (e[i]==0&&z==0)
                continue;
            else
            {
                cout<<e[i];
                z=1;
            }

        }
        cout<<endl;
        k++;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值