103 A+B Problem II

285 篇文章 1 订阅
176 篇文章 0 订阅


A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

void rev(char s1[])
{
    int i,j,l;
    char s2[1005];
    l=strlen(s1);
    for(i=l-1,j=0;i>=0;i--,j++)
        s2[j]=s1[i];
    s2[j]='\0';
    strcpy(s1,s2);
    for(i=j;i<=1000;i++)
        s1[i]='0';
    s1[1001]='\0';
}

int main()
{
    int t,i,j,la,lb,p,q;
    char a[1005],b[1005],c[1005];
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        scanf("%s%s",a,b);
        printf("Case %d:\n",i);
        printf("%s + %s = ",a,b);
        la=strlen(a);
        lb=strlen(b);
        rev(a); rev(b);
        q=0;
        for(j=0;j<=1000;j++)
        {
            p=(a[j]-'0')+(b[j]-'0')+q;
            c[j]=p%10+'0';
            q=p/10;
        }
        for(j=1000;j>=0 && c[j]=='0';j--);
        for(;j>=0;j--)
            printf("%c",c[j]);
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值