HDU 5924-Mr. Frog’s Problem

One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.

He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that A≤C≤B,A≤D≤BA≤C≤B,A≤D≤B and AB+BA≤CD+DCAB+BA≤CD+DC
Input
first line contains only one integer T (T≤125T≤125), which indicates the number of test cases. Each test case contains two integers A and B (1≤A≤B≤10181≤A≤B≤1018).
Output
For each test case, first output one line “Case #x:”, where x is the case number (starting from 1).

Then in a new line, print an integer s indicating the number of pairs you find.

In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.
Sample Input
2
10 10
9 27
Sample Output
Case #1:
1
10 10
Case #2:
2
9 27
27 9

打表 暴力找规律 发现2个数相同 结果为1 2个数不同结果有2个 换位输出

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int N;
    scanf("%d",&N);
    int t=1;
    while (N--)
    {
        long long int n,m;
        scanf("%lld%lld",&n,&m);

//        for (int i=n; i<=m; i++)
//        {
//            for (int j=n; j<=m; j++)
//            {
//                if (1.0*(n*n+m*m)/(m*n) <= 1.0*(i*i+j*j)/(i*j) )
//                    cout<<i<<" !!!!!! !!    "<<j<<endl;
//            }
//        }
        if (n==m)
        {
            printf("Case #%d:\n",t);
            t++;
            printf("1\n");
            printf("%lld %lld\n",n,m);
        }
        else
        {
            printf("Case #%d:\n",t);
            t++;
            printf("2\n");
            printf("%lld %lld\n",n,m);
            printf("%lld %lld\n",m,n);
        }


    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值