hdu5924 Mr. Frog’s Problem 打表找规律 国庆咸鱼

Mr. Frog’s Problem

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 25 Accepted Submission(s): 17


Problem Description
One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.

He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that ACB,ADB and AB+BACD+DC

Input
first line contains only one integer T ( T125 ), which indicates the number of test cases. Each test case contains two integers A and B ( 1AB1018 ).

Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1).

Then in a new line, print an integer s indicating the number of pairs you find.

In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.

Sample Input
  
  
2 10 10 9 27

Sample Output
  
  
Case #1: 1 10 10 Case #2: 2 9 27 27 9

Source
一开始在纸上写写画画了很久。。。并没有什么发现。。榜上面很多人过了这题。。。很sad。。。

然后自暴自弃地打了个1~100的表,发现怎么打都是那两个数


还真得就是那两个数。。。

打表代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
const double eps=1e-8;
int main(){
	int a,b,i,j;
	for(a=1;a<=100;a++){
		for(b=a;b<=100;b++){
			for(i=a;i<=b;i++){
				for(j=a;j<=b;j++){
					double mae,ato;
					mae=(pow(a,2)+pow(b,2))/((double)a*(double)b);
					ato=(pow(i,2)+pow(j,2))/((double)i*(double)j);
					if(abs(mae-ato)<eps){
						printf("A:%d B:%d C:%d D:%d\n",a,b,i,j);
					}
				}
			}
		}
	}
    return 0;
}

ac代码:

还是因为longlong   wa了几回。。。真心要注意细节啊,,,

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
long long a,b;
int main(){
    int t;
    scanf("%d",&t);
    int rnd=1;
    while(t--){
        scanf("%lld%lld",&a,&b);
        if(a==b){
            printf("Case #%d:\n1\n%lld %lld\n",rnd,a,b);
            rnd++;
        }else{
            if(a>b){
                swap(a,b);
            }
            printf("Case #%d:\n2\n%lld %lld\n%lld %lld\n",rnd,a,b,b,a);
            rnd++;
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值