HDU-3449 Consumer(有依赖背包)

Consumer

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 2382 Accepted Submission(s): 1266

Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output
For each test case, output the maximum value FJ can get

Sample Input
3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60

Sample Output
210

第一道有依赖背包问题, 其实这道题还是蛮简单的, 可能一看有依赖 这三个字有点蒙蔽 , 但大体过程和01背包类似 , 只是需要做一定的处理

题意:
给你一些物品,每个物品有自己的花费和价值,每个物品 都有相对应的箱子, 如果你想要买这个物品,你就需要先买这个箱子(依赖), 第一行先输入一个n 和t 代表 有几组物品 和你有多少钱(如果你要买该组物品,不管几个, 你都必须先买该组对应的箱子)

下面 n行 每行开头输入2个数据 box 和 num, box代表盒子的价钱, num代表该组的物品数, 后面2*num 个数据分别代表 每个物品的花费和价值

求 n个箱子花费 t 能获得的最大价值

分析:
既然是有依赖的问题, 那么我们当前组的dp值取决于上组的状态
那么对于本组就分 2种状态
1.不买:直接继承上组状态,然后处理
2.买: 继承上组状态, 然后减去盒子的花费,继续处理

先假设 我们需要买 :
首先解决有依赖性的问题:
当依次添加每组的物品时, 先要将dp的前box个数 赋初值为-1, 代表盒子占用了
在该组进行01 背包算出 最大价值

将买的和不买的比较 取最大价值

每组都重复操作最后即为结果

逼逼有点多 看代码:

#include<stdio.h>
#include<string.h>
#include<bits/stdc++.h>

using namespace std;
int dp[55][100010];
int n,t,box,num;
int main ()
{
    int i,j,k;
    while(scanf("%d %d",&n,&t)!=EOF)
    {
         memset(dp,0,sizeof(dp));//初始化背包
        for(i=1;i<=n;i++)
        {
            scanf("%d %d",&box,&num);
            for (int j=0; j<=box;j++) //对盒子的处理(即依赖)
                dp[i][j] = -1;
            for(k=t;k>=box;k--)
                dp[i][k]=dp[i-1][k-box]; //先让每组数据拿到上组的状态

           //下列操作先算出我需要该组物品(盒子)
            for(j=0;j<num;j++)
            {
                int c,w;
                scanf("%d %d",&c,&w);
                for(k=t;k>=c;k--)
                {
                    if(dp[i][k-c]!=-1)
                        dp[i][k]=max(dp[i][k],dp[i][k-c]+w);
                }
            }
            //取和不取的比较算出最大价值
            for(j=0;j<=t;j++)
            {
                dp[i][j]=max(dp[i-1][j],dp[i][j]);
            }
        }
        printf("%d\n",dp[n][t]);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值