hdu Consumer

Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.
 

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)
 

Output
For each test case, output the maximum value FJ can get
 

Sample Input
  
  
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60
 

Sample Output
  
  
210
题意:有n个盒子装的物品,有钱w,若买盒子内的物品必须买盒子,求买的物品最大价值
输入n w
盒子价钱 盒子内物品数 物品价钱 物品价值。。。。
#include<iostream>
#include<cmath>
#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<string.h>
#define INF 1e8
using namespace std;
int dp[56][200000];
int vis[30000];
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,-1,sizeof(dp));
        memset(dp[0],0,sizeof(dp[0]));
        for(int i=1;i<=n;i++)
        {
            int vs,vn;
            scanf("%d%d",&vs,&vn);
            for(int j=vs;j<=m;j++)//直接扣掉盒子钱
                dp[i][j]=dp[i-1][j-vs];
            for(int j=0;j<vn;j++)
            {
                int v,c;
                scanf("%d%d",&v,&c);
                for(int k=m;k>=v;k--)
                    if(dp[i][k-v]!=-1)//判断是否扣掉了盒子钱
                    {
                        dp[i][k]=max(dp[i][k],dp[i][k-v]+c);
                    }
            }
             for(int j=0;j<=m;j++)//判断买不买
                    dp[i][j]=max(dp[i-1][j],dp[i][j]);
        }
        printf("%d\n",dp[n][m]);

    }
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值