南邮 OJ 1091 Black Vienna

Black Vienna

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 53            测试通过 : 17 

比赛描述

This problem is based on the game of Black Vienna. In this version there are three players and 18 cards labeled A-R. Three of the cards are set aside (hidden) and form the "Black Vienna" gang. The remaining cards are shuffled and dealt to the players so that each player has 5 cards. Players never reveal their cards to each other. There is a separate deck of "interrogation cards" which contain three distinct letters in ascending order, like ACG or BHR.  Turns rotate through players 1, 2, and 3.  On each player's turn, that player selects an interrogation card, puts it face up in front of another player, and that other player must indicate the total number of these cards being held, without saying which ones.  All players see the result of the "interrogation". The play continues until a player deduces the three cards in the "gang".     
For example, suppose the cards are distributed as follows, and the game then proceeds:
Player 1: DGJLP; Player 2: EFOQR; Player 3: ACHMN;  Gang: BIK
Turn 1:  Player 1 interrogates player 2 with BJK; answer 0
Turn 2:  Player 2 interrogates player 3 with ABK; answer 1
Turn 3:  Player 3 interrogates player 2 with DEF; answer 2
Turn 4:  Player 1 interrogates player 2 with EIL; answer 1
Turn 5:  Player 2 interrogates player 3 with FIP; answer 0
Turn 6:  Player 3 interrogates player 1 with GMO; answer 1
Turn 7:  Player 1 interrogates player 2 with OQR; answer 3
Turn 8:  Player 2 interrogates player 3 with ADQ; answer 1
Turn 9:  Player 3 interrogates player 1 with EGJ; answer 2
In fact, the game does not need to get to turn 9.  With enough thought, player 1 can deduce after turn 8 that the gang is BIK.  It is your job to analyze records of games and deduce the earliest time that the gang could be determined for sure.


输入

The input will consist of one to twelve data sets, followed by a line containing only 0.   
The first line of a dataset contains the number, t, of turns reported, 2 ≤ t ≤ 15.  
The next line contains four blank separated strings for the hands of players 1, 2, and 3, followed by the cards for the gang.
The remaining t lines of the data set contain the data for each turn in order.  Each line contains three blank separated tokens:  the number of the player interrogated, the string of interrogation letters, and the answer provided.
All letter strings will contain only capital letters from A to R, in strictly increasing alphabetical order.  The same interrogation string may appear in more than one turn of a game.

输出

There is one line of output for each data set.  The line contains the single character "?" if no player can be sure of the gang after all the turns listed.  If a player can determine the gang, the line contains the earliest turn after which one or more players can be sure of the answer.

样例输入

9
DGJLP EFOQR ACHMN BIK
2 BJK 0
3 ABK 1
2 DEF 2
2 EIL 1
3 FIP 0
1 GMO 1
2 OQR 3
3 ADQ 1
1 EGJ 2
3
ABCDE FGHIJ KLMNO PQR
3 BKQ 1
1 ADE 3
2 CHJ 2
0

样例输出

8
?

题目来源

ACM Mid-Central Regional 2009




#include<iostream>
using namespace std;
 
const int PLAYERS = 3,  // check against final problem statement!
        MAX_TURNS = 15,
		HAND = 5,
		HID = 3,
		UNK = HID+HAND*(PLAYERS-1);

int turns;
 
char quest[MAX_TURNS][3+1], // interrogations
    hand[PLAYERS + 1][5+1], //actual hands, gang at end
    maybe[PLAYERS + 1][HAND+1]; //possible hands, gang
 
char unk[UNK]; // letters not in one player's hand

int who[MAX_TURNS],  // who interrogated
    matches[MAX_TURNS], // matches in interogation
    used[PLAYERS+1]; // amount of maybe hand filled

int solved;  // max turns needed for current player for comb. so far
 
int Max(int a,int b);
void solve(int i,char unk[]);
int countConsistent(char choice[][HAND+1]);
int countDups(char a1[],char a2[]);
 
int main()
{
    //freopen("in.txt","r",stdin);
    int i,j;
    int bestSolved;
    while(scanf("%d",&turns)!=EOF && turns>0)
    {
        for(i=0;i<=PLAYERS;i++)
            scanf("%s",&hand[i]);
        int t;
        for(t=0;t<turns;t++)
        {
            scanf("%d",&who[t]);
            who[t]--;  // internal 0 based
            scanf("%s",&quest[t]);
            scanf("%d",&matches[t]);
        }
        bestSolved=MAX_TURNS;
        int p;
        char unkStr[18-5+1];
        for(p=0;p<PLAYERS;p++)
        {
            memset(unkStr,'\0',sizeof(unkStr));
            for(j=0;j<=PLAYERS;j++){
                if(j!=p)
                    strcat(unkStr,hand[j]);
            }
            strcpy(maybe[p],hand[p]); // player knows own
            used[p] = HAND; // no further characters to choose
            solved = 0; // after recursion max turns to eliminate a maybe
            solve(0,unkStr);
            memset(maybe[p],'\0',sizeof(maybe[p]));
            used[p]=0;
            if(solved<bestSolved)
                bestSolved=solved;
        }
        if(bestSolved<turns)
            printf("%d\n",bestSolved+1);
        else
            printf("?\n");
    }//end while
    return 0;
}//end main()
 
int Max(int a,int b)
{    return (a>b)?a:b;    }
 
// accumulate combinations recursively, check when one is complete
void solve(int i,char unk[])
{
    if(i==(18-5)){ // assigned all choices, now check
        if (maybe[PLAYERS][0] == unk[i-HID]) return; //match end gang char
        solved = Max(solved, countConsistent(maybe));
    }
    else{
        int j;
        for(j=0;j<=PLAYERS;j++){
            if((j<PLAYERS && used[j]<5) || (j==PLAYERS && used[j]<3)){ //add char to partial hand
                maybe[j][used[j]]=unk[i];
                used[j]++;
                solve(i+1,unk);
                used[j]--; // undo change before trying next player
            }
        }
    }
}
 
// return first inconsistent turn (0 based) or total turns if consistent
int countConsistent(char choice[][HAND+1])
{
    int t=0;
    while(t<turns &&
        countDups(choice[who[t]],quest[t])==matches[t])
        t++;
    return t;
}
 
int countDups(char a1[],char a2[])
{
    int i,j;
    int n=0;
    for(i=0;i<5;i++){
        for(j=0;j<3;j++)
            if(a1[i]==a2[j])
                n++;
    }
    return n;
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值