南邮 OJ 1127 Stick

Stick

时间限制(普通/Java) :  2000 MS/ 6000 MS          运行内存限制 : 65536 KByte
总提交 : 194            测试通过 : 92 

比赛描述

Anthony has collected a large amount of sticks for manufacturing chopsticks. In order to simplify his job, he wants to fetch two equal-length sticks for machining at a time.  After checking it over, Anthony finds that it is always possible that only one stick is left at last,  because of the odd number of sticks and some other unknown reasons. For example, Anthony may have three sticks with length 1, 2, and 1 respectively. He fetches the first and the third for machining, and leaves the second one at last. Your task is to report the length of the last stick.

输入

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=100, and n is odd) at first. Following that, n positive integers will be given, one in a line. These numbers indicate the length of the sticks collected by Anthony.
The input is ended by n=0.

输出

For each case, output an integer in a line, which is the length of the last stick.

样例输入

3
1
2
1
0

样例输出

2

题目来源

第九届中山大学程序设计竞赛预选题




#include<iostream>
using namespace std;

int main(){
	int N,t,r;
	while(cin>>N && N){
		r = 0;
		while(N--){
			cin>>t;
			r ^= t;
		}
		cout<<r<<endl;
	}
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值