南邮 OJ 1557 Tower Parking

Tower Parking

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 11            测试通过 : 6 

比赛描述

There is a new revolution in the parking lot business: the parking tower. The concept is

simple: you drive your car into the elevator at the entrance of the tower, and the elevator

and conveyor belts drag the car to an empty parking spot, where the car remains until you

pick it up. When you return, the elevator and conveyor belts move your car back to the

entrance and you’re done.

The layout of the tower is simple. There is one central elevator that transports the cars

between the different floors. On each floor there is one giant circular conveyor belt on which

the cars stand. This belt can move in clockwise and counterclockwise direction. When the

elevator arrives on a floor, it becomes part of the belt so that cars can move through it.

At the end of the day the tower is usually packed with cars and a lot of people come to

pick them up. Customers are processed in a first come first serve order: the elevator is moved

to the floor of the first car, the conveyor belt moves the car on the elevator, the elevator is

moved down again, and so on. We like to know how long it takes before the last customer

gets his car. Moving the elevator one floor up- or downwards takes 10 seconds and moving

a conveyor belt one car in either direction takes 5 seconds.



输入

On the first line one positive number: the number of testcases, at most 100. After that per

testcase:

• One line with two integers h and l with 1 ≤ h ≤ 50 and 2 ≤ l ≤ 50: the height of the

parking tower and the length of the conveyor belts.

• h lines with l integers: the initial placement of the cars. The j th number on the ith line

describes the j th position on the ith floor. This number is −1 if the position is empty,

and r if the position is occupied by the rth car to pick up. The positive numbers form

a consecutive sequence from 1 to the number of cars. The entrance is on the first floor

and the elevator (which is initially empty) is in the first position. There is at least one

car in the parking tower.


输出

Per testcase:

• One line with the number of seconds before the last customer is served.


样例输入

2
1 5
-1 2 1 -1 3
3 6
-1 5 6 -1 -1 3
-1 -1 7 -1 2 9
-1 10 4 1 8 -1

样例输出

25
320

提示

undefined

题目来源

NWERC 2007




//AC 0MS
#include<iostream>
#define N 50
int x[N*N],y[N*N],c[N];

int main(){
//	freopen("test.txt","r",stdin);
	int t,h,l,i,j,k,n,time;
	scanf("%d",&t);
	while(t--){
		n = time = 0;
		memset(c,0,sizeof(c));		//WA1
		scanf("%d%d",&h,&l);
		for(i=0;i<h;i++){
			for(j=0;j<l;j++){
				scanf("%d",&k);
				if(k!=-1){
					x[k] = i;
					y[k] = j;
					if(n < k){
						n = k;
					}
				}
			}
		}
		for(k=1;k<=n;k++){
			j = y[k]-c[x[k]];	//所在点减去这一层目前的中心
			if(j<0){
				j = -j;
			}
			if(j>l-j){
				j = l-j;
			}
			time += (x[k])*20 + j*5;
			c[x[k]] = y[k];
		}
		printf("%d\n",time);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值