poj Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7457 Accepted: 3642

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

思路:递归加高精度;题目比较简单,就是问你用2*1和2*2的方块能有几种方法组合成2*n
递归 公式很容易得到,看图,我们可以假设当n=3时,方格组合可以有一个2*2和一个2*1的方式组合
当把2*1单独出来时,它一种组合方式,就是竖就一种。然后旁边就是一个2*2的方式。设当n=3时,设方法数为f(3)。
当只放入2*1方格时,方法就是2*1的方法,但是前面2*2用2*1有两种摆放方式就是横着和竖着。所以应该是2*f(1)
当推广到n时方法f(n)=f(n-1)+2*f(n-2);然后高精度的话我有两张方法,第一种就是用一个二维数组把数存起来,当数大于十时,就后面进一。然后我用的是java的高精度,推荐java吧
 
import java.math.BigInteger;
import java.util.Scanner;

public class qq {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		BigInteger a, b, c, d;
		c = BigInteger.ZERO;
		int i;
		int n ;
		
		while (cin.hasNext()) {
			a = BigInteger.valueOf(1);
		    b = BigInteger.valueOf(3);
			c = BigInteger.ZERO;
			n = cin.nextInt();
			if (n == 1||n==0) {
				c = a;
				System.out.println(c);
			} else if (n == 2) {
				c = b;
				System.out.println(c);
			} else {
				for (i = 3; i <= n; i++) {

					c = b.add(a.multiply(BigInteger.valueOf(2)));
					a=b;
					b=c;
				}
				System.out.println(c);
			}
		}

	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值