HDU 1034 Candy Sharing Game(水题)

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6781    Accepted Submission(s): 4131


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
  
  
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
  
  
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 

Source

题目大意:n个学生围成一个圈,初始时每人手里有偶数个糖,当老师吹一次口哨时,学生同时将手中的糖分一半给右边的同学;如果分完后有人手中是奇数个糖,老师就会向他手中再加一颗糖使其成为偶数;当所有人手里的糖数目相同时结束,输出老师吹口哨的次数和最终每人手中糖果数。

这一题就是一道模拟水题,将糖的传递过程模拟,然后判断奇偶,再判断数目是否一致即可。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#define N 222
using namespace std;
int a[N];
int judge(int n){//判断糖的数目是否一致
    int i;
    for(i=1;i<n;i++){
        if(a[i]!=a[i-1])
            break;
    }
    if(i>=n)
        return 1;
    else
        return 0;
}
int main(){
    int n;
    while(cin>>n&&n!=0){
        int sum=0;
        for(int i=0;i<n;i++)
            cin>>a[i];
        a[n]=a[0];//多开一个空间,将a[n]和a[0]赋值相等,模拟成一个圈,即:a[0],a[1],a[2]...a[n-1],a[0]
        while(!judge(n)){
            for(int i=n;i>0;i--){//从后往前循环,如果从前往后循环的话,a[i-1]数值的改变会影响a[i]的数值
                a[i]=a[i]/2+a[i-1]/2;
                if(a[i]&1)//位运算判断奇偶
                    a[i]++;
            }
            a[0]=a[n];//将a[n]的值赋给a[0]形成一个圈
            sum++;
        }
        cout<<sum<<" "<<a[0]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值