PAT A1103 Integer Factorization (30分) (DFS+剪枝)

PAT甲级:A1103 Integer Factorization (30分)

The KP factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the KP factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a1,a2,⋯,aK } is said to be larger than { b1,b2,⋯,bK } if there exists 1≤LK such that ai=bi for i<L and aL>bL.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible
  • 题意:整数因式分解,将一个整数N拆成K个数的P次方和,这里的P也是整数,如果找到符合的因数有多个则输出数字字典序较大的,例如 [10, 2, 1] 大于 [9, 9, 9],因为第一个10大于9。
  • 分析:本题考察DFS深度优先搜索,首先对于要满足的K的数的P次方和等于N,这所拆分的这几个数中最大的数要小于N,那么对于因子来说,它的P次方一样要小于N,因此在寻找这些数的时候,应该从N开P次方的数开始向下找,同时,题目要求输出满足结果中序列较大的那个,那么在DFS的时候就应该从可能的最大的数开始往下寻找。而在DFS时,存在两个分支,分别是当前数的选与不选,“死胡同”则是,当前记录的sum大于N、cntK大于K或者当前数X小于1时候,如果出现以上情况则返回。

注意:DFS时因为总是要用pow函数重复计算某个数的P次幂,导致存在一个样例超时,所以需要在深搜前把可能用到的数的P次幂先计算出来,按照下标依次存储。

#include <bits/stdc++.h>
using namespace std;
int n, k, p, maxFacSum = -1;
vector<int> temp, ans, fac;
void dfs(int x, int sum, int facSum, int cntK) {
    if (x < 1 || sum > n || cntK > k) return;
    if (sum == n && cntK == k) {
        if (facSum > maxFacSum) {
            ans = temp;
            maxFacSum = facSum;
        }
        return;
    }
    temp.push_back(x);
    dfs(x, sum + fac[x], facSum + x, cntK + 1);
    temp.pop_back();
    dfs(x - 1, sum, facSum, cntK);
}
int main() {
    scanf("%d%d%d", &n, &k, &p);
    int i = 0, temp = 0;
    while (temp <= n) {
        fac.push_back(temp);
        temp = pow(++i, p);
    }
    dfs((int)fac.size() - 1, 0, 0, 0);
    if (ans.size() == 0) printf("Impossible\n");
    else {
        printf("%d = ", n);
        for (int i = 0; i < ans.size(); i++) {
            if (i != 0) printf(" + ");
            printf("%d^%d", ans[i], p);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值