【PAT】A1103. Integer Factorization (30)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 1200 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1103. Integer Factorization (30)


The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

 

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

 

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + … nK^P

where ni (i=1, … K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen — sequence { a1, a2, … aK } is said to be larger than { b1, b2, … bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output “Impossible”.

Sample Input 1:


169 5 2


Sample Output 1:


169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2


Sample Input 2:


169 167 3


Sample Output 2:


Impossible

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int n,k,p,maxfsum;
vector<int> vfac,res,tempRes;
void dfs(int index,int nowK,int sum,int fsum){
    if(sum==n&&nowK==k){
        if(fsum>maxfsum){
            maxfsum=fsum;
            res=tempRes;
        }
        return;
    }
    if(sum>n||nowK>k)    return;
    if(index>=1){
        tempRes.push_back(index);
        dfs(index,nowK+1,sum+vfac[index],fsum+index);
        tempRes.pop_back();
        dfs(index-1,nowK,sum,fsum);
    }
}
int main(){
    scanf("%d %d %d",&n,&k,&p);
    for(int i=0;pow(i*1.0,p)<=n;i++) vfac.push_back(pow(i*1.0,p));
    maxfsum=-1;
    dfs(vfac.size()-1,0,0,0);
    if(res.size()==k){
        printf("%d = %d^%d",n,res[0],p);
        for(int i=1;i<res.size();i++){
            printf(" + %d^%d",res[i],p);
        }
    }
    else        printf("Impossible");
    return 0;
}

Analysis

-本题使用DFS剪枝最佳

以下是柳婼学姐的分析:

分析:dfs深度优先搜索。先把i从0开始所有的i的p次方的值存储在v[i]中,直到v[i] > n为止。然后深度优先搜索,记录当前正在相加的index(即v[i]的i的值),当前的总和tempSum,当前K的总个数tempK,以及因为题目中要求输出因子的和最大的那个,所以保存一个facSum为当前因子的和,让它和maxFacSum比较,如果比maxFacSum大就更新maxFacSum和要求的ans数组的值。

在ans数组里面存储因子的序列,tempAns为当前深度优先遍历而来的序列,从v[i]的最后一个index开始一直到index == 1,因为这样才能保证ans和tempAns数组里面保存的是从大到小的因子的顺序。一开始maxFacSum == -1,如果dfs后maxFacSum并没有被更新,还是-1,那么就输出Impossible,否则输出答案。

(PS:感谢github用户littlesevenmo提供的更优解)
分析:这道题考的是DFS+剪枝,我认为主要剪枝的地方有三个:
1. tempK==K但是tempSum!=n的时候需要剪枝
2. 在枚举的时候,按顺序枚举,上界或者下界可进行剪枝
3. 当且仅当tempSum + v[index] <= n时,进行下一层的DFS,而不要进入下一层DFS发现不满足条件再返回,这样开销会比较大~
————————————————
版权声明:本文为CSDN博主「柳婼」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/liuchuo/article/details/52493390

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值