PAT 1043 Is It a Binary Search Tree (25)

2 篇文章 0 订阅
1 篇文章 0 订阅

题目网址:https://www.patest.cn/contests/pat-a-practise/1043


题目:

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

这是一个二叉搜索树的题目,一直想要做二叉树练练手的,这个练手还是很爽的,有二叉树的建立,交换节点,先序遍历和后续遍历,顺便还练习了一遍vector的用法。


首先是什么都不管,先将给的数据按小的在左边,大于等于的在右边(第一个数为根节点),建立儿叉搜索树,然后再求出其前序遍历,比较是否同输入的序列相同,相同则输出“YES”,否则就输出“NO”,同时,如果是镜像,后序输出的时候还要交换节点

话不多说,上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

const int MAXN = 1010;

struct node{
    node *left;
    node *right;
    int val;
};

vector<int> vec, post;
vector<int> ok_list, mir_list;

void build(node *&p, int val)
{
    if(p == NULL)
    {
        p = new node;
        p->val = val;
        p->right = p->left = NULL;
        return ;
    }
    else{
        if(val < p->val)
        {
            build(p->left, val);
        }
        else if(val >= p->val)
        {
            build(p->right, val);
        }
    }
}

///中右左
void preorder(node *q)
{
    if(q == NULL)
    {
        return ;
    }
    ok_list.push_back(q->val);
    preorder(q->left);
    preorder(q->right);
}

///中左右
void mirorder(node *q)
{
    if(q == NULL)
    {
        return;
    }
    mir_list.push_back(q->val);
    mirorder(q->right);
    mirorder(q->left);
}

///后序遍历
void lastorder(node *q)
{
    if(q == NULL)
    {
        return;
    }
    lastorder(q->left);
    lastorder(q->right);
    post.push_back(q->val);
}
//将镜像二叉换回来
void change(node *p)
{
    if(p == NULL)
    {
        return ;
    }
    node *temp = p->left;
    p->left = p->right;
    p->right = temp;
    change(p->left);
    change(p->right);
}
///输出vector的值
void print()
{
    cout << post[0];
    for(int i = 1; i < post.size(); i++)
    {
        cout << " " << post[i];
    }
    cout << endl;
}

int main()
{
    int n;
    cin >> n;
    node *p = NULL;
    for(int i = 0; i < n; i++)
    {
        int t;
        cin >> t;
        build(p, t);
        vec.push_back(t);//保存原有的序列
    }

    preorder(p);
    mirorder(p);

    if(vec == ok_list)
    {
        cout << "YES" << endl;
        post.clear();
        lastorder(p);
        print();
    }
    else if(vec == mir_list)
    {
        cout << "YES" << endl;
        post.clear();
        change(p);
        lastorder(p);
        print();
    }
    else
    {
        cout << "NO" << endl;
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值