poj 1308 Is It A Tree? 数据结构 并查集

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

并查集:

数据不强,下图明显不是一颗树,而是一个环与一棵树。居然让我ac了。

1 2

2 3

3 1

4 5

0 0

以上的思路就是记录每个节点的状态,是否为根节点,首先每个节点都是根节点

我们知道一个节点不能有两个父亲,即输入(a,b),只有b为根点时才为真。

然后检查最后是否只有一个根节点。


扫除盲点:在加一个条件,一旦a,b是在同一颗树上,是为假。虽然又ac了,以上数据过了,但心里还是没底。


#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<vector>
using namespace std;
const int n = 10010;
int fa[n];
int is_root[n];
bool vis[n];
void init(){
	int i; 
	for(i=1;i<=n-10;i++)
	{
		fa[i] = i;
		is_root[i] = 1;	
	}
}
int find(int x){
	if(x!=fa[x])
	{
		fa[x] = find(fa[x]);
	}
	return fa[x];
}
int Union(int x,int y){
	int rx,ry;
	ry = find(x);
	rx = find(y); 
	if(rx==ry)   //盲点
	return 0;
	if( is_root[y]==0 )
	return 0;
	fa[rx] = ry;
	is_root[rx] = 0;
	return 1;
}
int main()
{
	int i,j,k,m,a,b;
	int fg=1;
	int T=1;
	init();
	int time=0;
	while(scanf("%d%d",&a,&b)!=EOF){
		
		if(a==-1&&b==-1)
		break;
		if(a!=0&&a==b)
		fg=0;
		vis[a]=1;
		vis[b]=1;
		if(a==0){
			if(!fg){
				printf("Case %d is not a tree.\n",T++);
			}
			else {
				int t=0;
				for(i=1;i<=n-10;i++)
				if(vis[i]&&is_root[i]) t++;
				if(t == 1 ||time==0&&t==0)
				printf("Case %d is a tree.\n",T++);	
				else printf("Case %d is not a tree.\n",T++);
			}
			fg=1;init();
			memset(vis,0,sizeof(vis));
			time=0;
			continue;
		}
		if(Union(a,b)==0)
		fg=0;
		time ++;
	}
	return 0;
}

可以借鉴别人的思路:

思路:并查集的应用。重点在于考虑情况要全。

      1:0 0  空树是一棵树 (自己就卡在这里)
     2: 1 1 0 0  不是树 不能自己指向自己
     2: 1 2 1 2 0 0  不是树 自己开始一直在这么WA 好郁闷 重复都不行呀~~5555

      2:1 2 2 1 0 0  也是错误的

 

     (2类归纳为:节点不能指向自己集合的任一元素)
     3: 1 2 2 3 4 5  不是树 森林不算是树



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值