poj 1988 Cube Stacking 数据结构 并查集

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 22067 Accepted: 7736
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


【题意】

有几个stack,初始里面有一个cube。支持两种操作:1.move x y: 将x所在的stack移动到y所在stack的顶部。2.count x:数在x所在stack中,在x之下的cube的个数。

【题解】

其实如果暴力思路求解就是把每个stack看成一个线性表,然后合并,毫无疑问会T掉。

但是话说用并查集解我也是惊了。怎么也想不到居然可以ac。


m a b其实我们只关心a和b的根节点是谁,因为a与b合并就意味着以后a与b所在的集合为一个集合。因此可以用并查集来解答。


首先我们用s数组保存以该节点为根节点的孩子个数。合并时,我们只需把s数组累加。那么如果只查询根节点的ans值,我们就可直接输出s数组的对应值。

但如果是查询非根节点?

于是我们需要再用一个数组d来保存此节点到其根节点的距离,于是结果值就为s【根节点】 - d【此节点】。

具体参考代码。


#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<vector>
using namespace std;
char a[10];
int fa[30010];
int s[30010];
int d[30010];

int find(int v){
	if(v != fa[v]){
		int tmp = fa[v];
		fa[v] = find(fa[v]);
		d[v] += d[tmp];   //d[v] = d[v] + 1 不一定是+1,因为d[dy] = s[dx]+1;,d数组的值与s数组大小有关 
 	}
	return fa[v];
}

void Union(int x,int y){
	int dx,dy;
	dx = find(x);
	dy = find(y);
	fa[dy] = dx;
	d[dy] = s[dx]+1;
	s[dx] += s[dy]+1;	
	//printf("x = %d %d\n",dy,d[dy]);
}
int main()
{
	int i,j,k,m;
	int u,v;
	int n;
	for(i=0;i<30010;i++){
			fa[i] = i;
			s[i] = 0;
			d[i] = 0;
	}
    scanf("%d",&n) ;
	{
			while(n--){
				scanf("%s",a);
				if(a[0] == 'M'){
					scanf("%d%d",&v,&u);
					Union(v,u);
				}
				else {
					scanf("%d",&v);
					u = find(v);
					//printf("%d %d %d\n",1,s[1],d[v]);
					printf("%d\n",s[u] +1 - (d[v]+1));
				}
			} 
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值