POJ2586 Y2K Accounting Bug (簡單貪心問題)

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

Waterloo local 2000.01.29


若明白題意,這道題是比較簡單的。
題目大意:有一個公司,該公司每個月的盈利或虧損是固定的,分別爲s和d。每5個月公布一次經營狀況,一年共公布8次(1-5,2-6...8-12)。而且這8次都是虧損的。現在題目給出s和d,求這一年最大的盈利可以是多少。如果沒有可能盈利,這輸出Deficit。

分析:首先我們可以確定,要使盈利盡可能大,則虧損的月份應該盡量少。所以應用貪心策勵可以得出下表(轉自discuss的表)
在保证连续5个月都亏损的前提下,使得每5个月中亏损的月数最少。根据d和s的不同五种情况
              x=1:  ssssd,ssssd,ss    d>4s     赢利10个月    10s-2d
              x=2:  sssdd,sssdd,ss    2d>3s    赢利8个月     8s-4d
              x=3:  ssddd,ssddd,ss    3d>2s    赢利6个月     6s-6d
              x=4:  sdddd,sdddd,sd    4d>s     赢利3个月     3s-9d  //要特別注意這一種情況
              x=5:  ddddd,ddddd,dd         无赢利
注意:0也算是盈利

以上表中的正確性,可以通過貪心來證明。簡單來說就是在每五個月中,若選定了一種五個月中d的月份數,則應當讓這8次都只含有這麼多個d月份數,這樣才可以騰出更多的總s月份數。

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;

int main()
{
    long long ans, s, d;
    while(~scanf("%lld%lld", &s, &d)){
        if(d > s * 4) ans = 10 * s - 2 * d;
        else if(2 * d > 3 * s) ans = 8 * s - 4 * d;
        else if(3 * d > 2 * s) ans = 6 * s - 6 * d;
        else if(4 * d > s) ans = 3 * s - 9 * d;
        else ans = -1;
        if(ans >= 0) printf("%lld\n", ans);
        else printf("Deficit\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值