POJ3295 Tautology (遞歸+構造)

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source

Waterloo Local Contest, 2006.9.30


題目大意:給你一個字符串,依據題目給出來的邏輯判斷,讓你判斷對於5種小寫字母(可以取0,1),是不是都滿足字符串爲1。

分析:直接掃一遍字符串就行,if情況比較多,得有耐心。


#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;

const int n = 1<<5;
string ss;
int len;
int cur;
int wf[5];

bool solve()
{
    int w, x;
    if(cur == len) return 1;
    char ch = ss[cur++];
    if(ch == 'K') {
        w = solve();
        x = solve();
        return (w && x);
    }
    else if(ch == 'A') {
        w = solve();
        x = solve();
        return (w || x);
    }
    else if(ch == 'N') {
        w = solve();
        return (!w);
    }
    else if(ch == 'C') {
        w = solve();
        x = solve();
        return (!(w && !x));
    }
    else if(ch == 'E') {
        w = solve();
        x = solve();
        return (w == x);
    }
    else if(ch == 'p') return wf[0];
    else if(ch == 'q') return wf[1];
    else if(ch == 'r') return wf[2];
    else if(ch == 's') return wf[3];
    else if(ch == 't') return wf[4];
}

int main()
{
    while(cin >> ss) {
        if(ss[0] == '0') break;
        len = ss.length();
        int ok = 1;
        for(int i = 0; i < n; ++i) {
            int tag = i;
            for(int j = 0; j < 5; ++j) {
                wf[j] = tag % 2;
                tag /= 2;
            }
            cur = 0;
            if(!solve()) ok = 0;
        }
        if(ok) printf("tautology\n");
        else printf("not\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值