hdu 【4198】Quick out of the Harbour

Quick out of the Harbour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1581    Accepted Submission(s): 625


Problem Description
Captain Clearbeard decided to go to the harbour for a few days so his crew could inspect and repair the ship. Now, a few days later, the pirates are getting landsick(Pirates get landsick when they don't get enough of the ships' rocking motion. That's why pirates often try to simulate that motion by drinking rum.). Before all of the pirates become too sick to row the boat out of the harbour, captain Clearbeard decided to leave the harbour as quickly as possible.
Unfortunately the harbour isn't just a straight path to open sea. To protect the city from evil pirates, the entrance of the harbour is a kind of maze with drawbridges in it. Every bridge takes some time to open, so it could be faster to take a detour. Your task is to help captain Clearbeard and the fastest way out to open sea.
The pirates will row as fast as one minute per grid cell on the map. The ship can move only horizontally or vertically on the map. Making a 90 degree turn does not take any extra time.
 

Input
The first line of the input contains a single number: the number of test cases to follow. Each test case has the following format:
1. One line with three integers, h, w (3 <= h;w <= 500), and d (0 <= d <= 50), the height and width of the map and the delay for opening a bridge.
2.h lines with w characters: the description of the map. The map is described using the following characters:
—"S", the starting position of the ship.
—".", water.
—"#", land.
—"@", a drawbridge.
Each harbour is completely surrounded with land, with exception of the single entrance.
 

Output
For every test case in the input, the output should contain one integer on a single line: the travelling time of the fastest route to open sea. There is always a route to open sea. Note that the open sea is not shown on the map, so you need to move outside of the map to reach open sea.
 

Sample Input
  
  
2 6 5 7 ##### #S..# #@#.# #...# #@### #.### 4 5 3 ##### #S#.# #@..# ###@#
 

Sample Output
  
  
16 11
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4203  4205  4206  4199  4197 
 

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
using namespace std;
const int maxn = 505;
int h,w,d;
int sx,sy;
int vis[maxn][maxn];
char map[maxn][maxn];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};

struct Node
{
    int x,y,t;
    bool operator < (const Node temp)const  //注意这里重载小于运算符的写法
    {
        return t > temp.t;          
    }
};

int BFS()
{
    Node pre,cur;
    priority_queue <Node> pq;
    while(!pq.empty()) pq.pop();    //上一步可能优先队列中还有元素
    memset(vis,0,sizeof(vis));
    vis[sx][sy] = 1;
    pre.x = sx;
    pre.y = sy;
    pre.t = 0;
    pq.push(pre);
    while(!pq.empty())
    {
        pre = pq.top();
        pq.pop();
        for(int i = 0; i < 4; i++)
        {
            int x = pre.x + dir[i][0];
            int y = pre.y + dir[i][1];
            if(x < 0 || x >= h || y < 0 || y >= w)
                return pre.t + 1;
            if(!vis[x][y] && map[x][y] != '#')
            {
                vis[x][y] = 1;
                cur.x = x;
                cur.y = y;
                if(map[x][y] == '@')
                    cur.t = pre.t + 1 + d;
                else
                    cur.t = pre.t + 1;
                pq.push(cur);
            }
        }
    }

}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d%d",&h,&w,&d);
        for(int i = 0; i < h; i++)
            scanf("%s", map[i]);
        for(int i = 0; i < h; i++)
            for(int j = 0; j < w; j++)
                if(map[i][j] == 'S')
                {
                    sx = i;
                    sy = j;
                }
        printf("%d\n",BFS());
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值