POJ 【3278】 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 70204 Accepted: 22082

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


/*
*这道题有几个坑点需要注意,首先我们可以判断出负坐标是没有作用的
*判断数组需要开2倍大,第二数组处理过程中不能越界.
*/
#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
using namespace std;
const int maxn = 100005;
int vis[2*maxn];
int n,k;
struct Node
{
    int x,t;
    Node(int a,int b):x(a),t(b){}
    Node(){}
};

bool judge(int loc)
{
    if(loc < 0 || loc >= 2*maxn)
        return false;
    return true;
}

void bfs()
{
    queue <Node> que;
    while(!que.empty()) que.pop();
    Node cur;
    memset(vis,0,sizeof(vis));
    que.push(Node(n,0));
    vis[n] = 1;
    while(!que.empty())
    {
        cur = que.front();
        que.pop();
        if(cur.x == k)
        {
            printf("%d\n",cur.t);
            return ;
        }
        if(judge(cur.x+1) && !vis[cur.x+1]) // 注意judge放在判断vis数组前面,否则会runtime error
        {
            vis[cur.x+1] = 1;
            que.push(Node(cur.x+1,cur.t+1));
        }
        if(judge(cur.x-1) && !vis[cur.x-1])
        {
            vis[cur.x-1] = 1;
            que.push(Node(cur.x-1,cur.t+1));
        }
        if(judge(cur.x*2) && !vis[cur.x*2])
        {
            vis[cur.x*2] = 1;
            que.push(Node(cur.x*2,cur.t+1));
        }
    }
}

int main()
{
    while(scanf("%d%d", &n, &k) != EOF)
        bfs();
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值