FZU 2110 Star

 Problem 2110 Star

Accept: 477    Submit: 1422
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Overpower often go to the playground with classmates. They play and chat on the playground. One day, there are a lot of stars in the sky. Suddenly, one of Overpower’s classmates ask him: “How many acute triangles whose inner angles are less than 90 degrees (regarding stars as points) can be found? Assuming all the stars are in the same plane”. Please help him to solve this problem.

 Input

The first line of the input contains an integer T (T≤10), indicating the number of test cases.

For each test case:

The first line contains one integer n (1≤n≤100), the number of stars.

The next n lines each contains two integers x and y (0≤|x|, |y|≤1,000,000) indicate the points, all the points are distinct.

 Output

For each test case, output an integer indicating the total number of different acute triangles.

 Sample Input

130 010 05 1000

 Sample Output

1

 Source

“高教社杯”第三届福建省大学生程序设计竞赛
#include <iostream>
#include <algorithm>
using namespace std;

struct point{
	double x,y;
}p[105];
double dis[105][105];
int main(){
	int T;
	cin>>T;
	while(T--){
		int n;
		cin>>n;
		for(int i=0;i<n;i++){
			cin>>p[i].x>>p[i].y;
		}
		for(int i=0;i<n-1;i++){
			for(int j=i+1;j<n;j++){
				dis[i][j]=(p[j].x-p[i].x)*(p[j].x-p[i].x)+(p[j].y-p[i].y)*(p[j].y-p[i].y);
			}
		}
		double b[3];
		int count=0;
		
		for(int i=0;i<n-2;i++){
			for(int j=i+1;j<n-1;j++){
				for(int k=j+1;k<n;k++){
					b[0]=dis[i][j];
					b[1]=dis[j][k];
					b[2]=dis[i][k];
					sort(b,b+3);
					if((b[0]+b[1])>b[2])
						count++;	
				}
			}
		}
		cout<<count<<endl;
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值