-----找规律 hdu 6090-Rikka with Graph

Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j, we make dist(i,j) equal to n.

Then, we can define the weight of the graph G (wG) as ∑ni=1∑nj=1dist(i,j).

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(i≠j) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).

Input

The first line contains a number t(1≤t≤10), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤106,1≤m≤1012).

Output

For each testcase, print a single line with a single number – the answer.

Sample Input

1
4 5

Sample Output

14

题目大意:
给你n个节点,让你选择m条边相连,dis[i][j]定义为i点和j点之间的最短路径,求图的最小权重,权重定义为:这里写图片描述

(2)图:

这里写图片描述

(3)图:
这里写图片描述

 解题思路:
(1).n个节点最多可以构成n*(n-1)条边,里面的每一条边都是双向的,所以当m>=n*(n-1)/2,w=n*(n-1);
(2).当m>=(n-1),正好让n个节点构成一个连通图,此时以某一个点为中心点其他点都与之相连能够使得权重最小,w=2*m+2*(n*(n-1)-2*m);
(3).当m<n-1,存在着游离的点,m条边,也就是说有m+1个点是联通的,n-m-1个点是游离的,w=2*m+2*m*(m-1)+n*(n*(n-1)-2*m-m*(m-1)); 


#include <iostream>
#include <stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

typedef long long ll;
int main()
{
   ll n,m;
   int t;
   scanf("%d",&t);
   while(t--)
   {
        scanf("%lld%lld",&n,&m);
        if(n==1)
        {
            printf("0\n");
            continue;
        }
       if(m>=n*(n-1)/2)
       {
           printf("%lld\n",n*(n-1));
           continue;
       }
       if(m>=n-1) printf("%lld\n",2*m+2*(n*(n-1)-2*m));
       if(m<n-1) printf("%lld\n",2*m+2*m*(m-1)+n*(n*(n-1)-2*m-m*(m-1)));
     }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值