-----找规律 ZOJ 3829-Known Notation

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven’t learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write “3 4 +” rather than “3 + 4”. If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written “3 - 4 + 5” in conventional notation would be written “3 4 - 5 +” in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression “5 + ((1 + 2) × 4) - 3” can be written down like this in RPN: “5 1 2 + 4 × + 3 -“. An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk “*” as the only operator and digits from “1” to “9” (without “0”) as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a “1” at the beginning of “2*3*4”, the string becomes “12*3*4”.
Swap. You can swap any two characters in the string. For example, if you swap the last two characters of “12*3*4”, the string becomes “12*34*”.
The strings “2*3*4” and “12*3*4” cannot represent any valid RPN, but the string “12*34*” can represent a valid RPN which is “1 2 * 34 *”.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output
For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input
3
1*1
11*234**
*
Sample Output
1
0
2
题意:
给你一个字符串,问你至少要经过多少个操作够能把它变成逆波兰数,操作可以是插入一个字符,也可以是交换两个字符的位置
解题思路:
就是找规律….
1.数字的数目(num)>=星星的数目(start)+1
2.若是条件1不满足,则先插入数字,每次插入数字应该插在字符串最前面的位置(因为数字之间的空格是随意控制的,所以最好的情况,就是数字都在前面,*都在后面),插入缺少的数字之后,若仍不满足就应该进行交换操作;一开始条件1就是满足的,则直接交换
3.交换的话,一开始初始化数据,数目start=0,数字的数目num=lack(缺少的数字的数目);开始遍历字符串,遇到的话start++,遇到数字的话num++,如果start+1>num,则不符合,这个时候就把星号和字符串最后一个数字交换,操作数目ans++,数字数目num++,星号数目start–;遍历完成后,ans+lack就是最少的操作数目

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;

char str[2010];

int main()
{
    int num,start,t,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        num=start=0;
        int len=strlen(str);
        for(int i=0;i<len;i++)
        {
             if(str[i]=='*') start++;
        else num++;
        }
         int lack=(start+1)-num;
         lack=max(lack,0);
         int start=0,num=lack,ans=lack;
         for(int i=0;i<len;i++)
         {
             if(str[i]=='*') start++;
                else num++;
             if(start+1>num)
                start--,num++,ans++;
         }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值