算法训练 操作格子
时间限制:1.0s 内存限制:256.0MB
问题描述
有n个格子,从左到右放成一排,编号为1-n。
共有m次操作,有3种操作类型:
1.修改一个格子的权值,
2.求连续一段格子权值和,
3.求连续一段格子的最大值。
对于每个2、3操作输出你所求出的结果。
输入格式
第一行2个整数n,m。
接下来一行n个整数表示n个格子的初始权值。
接下来m行,每行3个整数p,x,y,p表示操作类型,p=1时表示修改格子x的权值为y,p=2时表示求区间[x,y]内格子权值和,p=3时表示求区间[x,y]内格子最大的权值。
输出格式
有若干行,行数等于p=2或3的操作总数。
每行1个整数,对应了每个p=2或3操作的结果。
样例输入
4 3
1 2 3 4
2 1 3
1 4 3
3 1 4
1 2 3 4
2 1 3
1 4 3
3 1 4
样例输出
6
3
3
数据规模与约定
对于20%的数据n <= 100,m <= 200。
对于50%的数据n <= 5000,m <= 5000。
对于100%的数据1 <= n <= 100000,m <= 100000,0 <= 格子权值 <= 10000。
#include<Stdio.h>
#include<stdlib.h>
#define N 100001
typedef struct _Node
{
int left,right;
int max;
int sum;
struct _Node *pLeft,*pRight;
}Node,*pNode;
int sum = 0;
int max = 0;
int tab[N];
void Init(pNode *root,int left,int right);
void Insert(pNode root,int inx,int n);
void Change(pNode root,int x,int y);
void Max(pNode root,int x,int y);
void Sum(pNode root,int x,int y);
int main()
{
int n, m;
int p, x, y;
int i, j;
scanf("%d %d", &n, &m);
pNode root;
Init(&root,1,n);
for(i=1;i<=n;i++)
{
scanf("%d", &tab[i]);
Insert(root,i,tab[i]);
}
for(i=0;i<m;i++)
{
scanf("%d %d %d", &p, &x, &y);
switch(p)
{
case 1:
Change(root,x,y);
break;
case 2:
sum = 0;
Sum(root,x,y);
printf("%d\n",sum);
break;
case 3:
max = 0;
Max(root,x,y);
printf("%d\n",max);
break;
default:
break;
}
}
return 0;
}
void Init(pNode *root,int left,int right) //初始化线段树
{
if(left < right)
{
*root = (pNode)malloc(sizeof(Node));
pNode p =*root;
p->left = left;
p->right = right;
p->max = p->sum = 0;
p->pLeft = p->pRight = NULL;
Init(&(p->pLeft),left,(left+right)/2);
Init(&(p->pRight),(left+right)/2+1,right);
}
else if(left == right)
{
*root = (pNode)malloc(sizeof(Node));
pNode p =*root;
p->left = left;
p->right = right;
p->max = p->sum = 0;
p->pLeft = p->pRight = NULL;
}
}
void Insert(pNode root,int inx,int n) //插入值
{
if( root && root->left <= root->right )
{
root->sum += n;
if(root->max < n)
{
root->max = n;
}
int x = (root->left + root->right)/2;
if(inx <= x)
{
Insert(root->pLeft,inx,n);
}
else
{
Insert(root->pRight,inx,n);
}
}
}
void Change(pNode root,int x,int y)
{
if( x >= root->left && x <= root->right )
{
if(x == root->left && x == root->right)
{
root->max = root->sum = y;
return ;
}
else
{
int l = (root->left + root->right)/2;
if(x <= l)
{
Change(root->pLeft,x,y);
}
else
{
Change(root->pRight,x,y);
}
root->max = root->pLeft->max > root->pRight->max?root->pLeft->max:root->pRight->max;
root->sum = root->pLeft->sum + root->pRight->sum;
}
}
}
void Sum(pNode root,int x,int y)
{
if( x==root->left && y==root->right)
{
sum += root->sum;
return ;
}
int n = (root->left + root->right)/2;
if( x>=root->left && y<=n)
{
Sum(root->pLeft,x,y);
return ;
}
if( x>=n+1 && y<=root->right)
{
Sum(root->pRight,x,y);
return ;
}
Sum(root->pLeft,x,n);
Sum(root->pRight,n+1,y);
}
void Max(pNode root,int x,int y)
{
if( x==root->left && y==root->right)
{
if(root->max >max)
{
max = root->max;
}
return ;
}
int n = (root->left + root->right)/2;
if( x>=root->left && y<=n)
{
Max(root->pLeft,x,y);
return ;
}
if( x>=n+1 && y<=root->right)
{
Max(root->pRight,x,y);
return ;
}
Max(root->pLeft,x,n);
Max(root->pRight,n+1,y);
}