*寒假水106——素数环 搜索

 

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 

Inputn (0 < n < 20). 
OutputThe output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

#include<iostream>  
#include<string.h>
#include<stdio.h>

using namespace std;

int sushu[40]={0,1,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};//素数打表,因为n最大是20,所以只要打到40  
int xin[21],pei[21];  
int n;  

void dfs(int a) 
{  
   int i;  
   if(a==n&&sushu[pei[a-1]+pei[0]]) 
   {  
       for(i=0;i<a-1;i++)  
           cout<<pei[i]<<" ";  
       cout<<pei[a-1]<<endl;  
   }  
   else  
   {  
       for(i=2;i<=n;i++)  
       {  
           if(!xin[i]) 
           {  
               if(sushu[i+pei[a-1]]) 
               {  
                   xin[i]=-1;
                   pei[a++]=i; 
                   dfs(a); 
                   xin[i]=0;
                   a--;  
               }  
           }  
       }  
   }  
}     
 
int main()  
{  
      int num=0;  
      while(cin>>n)  
      {  
         num++;  
         printf("Case %d:\n",num);  
         memset(xin,0,sizeof(xin));  
         pei[0]=1;  
         dfs(1);  
         cout<<endl;  
      }  
      return 0;  
} 

题解:看到题目时我就按捺不住内心的激动,没错,王岐叔叔让我们写过这道题。想当初,那是一个温暖的阳光洒进教室来的午后,我爬在桌子上想这道题,嗯,我果然睡着了,一觉起来夕阳都没了。好在很快写下了这道题的框架。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值