*寒假水114——贪心【状压】

 

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

InputThe input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 
OutputFor each test case, you should output the smallest total reduced score, one line per test case. 
Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define max (1<<15)+5

using namespace std;

const int inf=1<<30;
int n,m;
int d[20],f[20];
int pre[max],t[max],dp[max];
char a[20][110];

void output(int x)
{
	if(!x)
		return ;
	output(x-(1<<pre[x]));
	printf("%s\n",a[pre[x]]);
}

int main ()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		cin>>n;
		for(i=0;i<n;i++)
		{
			cin>>a[i]>>d[i]>>f[i];
		}
		m=1<<n;
		for(i=1;i<m;i++)
		{
			dp[i]=inf;
			for(j=n-1;j>=0;j--)
			{
				int temp=1<<j;
				if((temp&i)==0)
					continue;
				int dec=t[i-temp]+f[j]-d[j];
				if(dec<0)
					dec=0;
				if(dp[i]>dp[i-temp]+dec)
				{
					dp[i]=dp[i-temp]+dec;
					t[i]=t[i-temp]+f[j];
					pre[i]=j;
				}
			}

		}
		cout<<dp[m-1]<<endl;
		output(m-1);
	}
	return 0;
}

题解:

 

假设dp[ _ , _ , _ , …… , _ , _ , _ ]记录了:n门课,在一些完成了,一些未完成的状态下,当前已经花去的时间(time),以及,当前已经被扣掉的最少分数(rs);

例如:有3门课,那么dp[0,0,0]代表了三门课作业还未做完的状态,dp[0,1,1]代表第二门和第三门的作业已经做完,第一门课作业还没做完的状态;

那么,我们状态转移方程:

  

  也就是说,dp[…1…]表示当前状态下第k门课已完成;

  那么,在dp[…0…]状态下,“已花费的时间 + 完成第k门课所需的时间 - 这门课的deadline”表示当前状态下开始做第k门课的作业,会导致扣多少分(记为red_sco)。

  如果red_sco + dp[…0…].rs 比 dp[…1…].rs 小,说明我们可以更新一下dp[…1…],它的rs可以更小;

 

然后,由于一门课的作业,只有做完和还没做完两个状态,所以我们dp[ _ , _ , _ , …… , _ , _ , _ ]里的n个数字,合起来看就是一个二进制数;

那么我们把它转换成十进制,其实并不影响实际的状态转移操作,故我们可以对这个状态进行压缩(原本n位的二进制数字可以压缩的很小位数的十进制数),即状压DP;

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值