hdu 1074 Doing Homework (状压dp)

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10029    Accepted Submission(s): 4800


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
  
  
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
  
  
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 

Author
Ignatius.L



第一次写状压。。。

题意:

共有n份作业 
每份作业的名字 截至时间  完成所需时间

超过规定时间我们就要扣一分,这里我们询问最少扣分
dp
状压dp
0代表这个作业尚未被完成 1代表已完成
共有1<<n-1种情况
我们需要dp出全部完成的最小扣分
详细题解看代码注释:


#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<iostream>
#include<stack>
using namespace std;
#define inf 0x3f3f3f3f
string name[20];///名字
int dead[20];///结束时间
int cost[20];///需要花费的时间
struct data
{
    int time,pre,now;/// 到达这个状态所需要的
    int score;///用来存储得分
} dp[1<<15];///n最大为15 所以1<<15个位置就够用了
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        cin>>n;
        for(int i=0; i<n; i++)
        {
            cin>>name[i]>>dead[i]>>cost[i];
        }
        memset(dp,0,sizeof(dp));///清空数组
        int right = 1<<n;///状态量
        for(int i=1; i<right; i++)///从 1 到 n个 1
        {
            dp[i].score=inf;///先将时间最大化
            for(int j=n-1; j>=0; j--)/// 题目要求按照相同的按照题目顺序更新
            {
                int tmp= 1<<j;
                if(tmp&i)///这个状态可以由nex状态添加一个完成
                {
                    int nex=i-tmp;
                    int spend_time=dp[nex].time+cost[j]-dead[j];///完成这项作业的耗时-规定期限==扣分数
                    if(spend_time<0)///如果扣分数为负数那么可以确定不扣分 spend_time=0
                        spend_time=0;
                    if(spend_time+dp[nex].score<dp[i].score)///数据更新
                    {
                        dp[i].score=dp[nex].score+spend_time;///最小分数
                        dp[i].pre=nex;///前一个状态
                        dp[i].now=j;///变为当前状态所需要添加的作业编号
                        dp[i].time=dp[nex].time+cost[j];///已经花费的时间
                    }
                }
            }
        }
        int tmp=right-1;
        cout<<dp[tmp].score<<endl;///输出完成所有作业的最小扣分数
        string res[20];
        int c=0;
        while(tmp)///从后往前存储名字。
        {
            res[c++]=name[dp[tmp].now];
            tmp=dp[tmp].pre;
        }
        for(int i=c-1;i>=0;i--)///正过来输出名字
        {
            cout<<res[i]<<endl;
        }
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值