浙江大学PAT上机题解析之1015. Reversible Primes (20)

74 篇文章 0 订阅
本文介绍了在数制D中,如何判断正整数N是否为反转素数,即其反转数也是素数。例如,在十进制下,73是一个反转素数,因为37也是素数。输入包含多个测试用例,每个用例包含正整数N和D(N<10^5, 1<D<=10),输出N在基数D下是否为反转素数。" 6545173,918676,ADO连接数据库错误解析:SQL语句与环境差异问题,"['数据库开发', 'SQL Server', 'ADO编程', 'MFC应用', '日期时间处理']
摘要由CSDN通过智能技术生成

 

时间限制 
400 ms
内存限制 
32000 kB
代码长度限制 
16000 B
判题程序   
Standard
作者   
CHEN, Yue

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases.  Each case occupies a line which contains two integers N and D.  The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
//这道题一开始没看懂题意,还以为是把数字逆序判素数呢,后来才知道是进制转换和素数判断
#include <iostream>

using namespace std;

bool isPrime(int k)
{  
 if(k==0||k==1) return false;
 if(k==2||k==3) return true;
for(int i=2;i*i<=k;i++)
if(k%i==0) return false;
return true;    
}

long  getReverse(long n,int radix)
{
  long num=n%radix; 
  while((n/radix)!=0)
  {
     n/=radix;               
     num = num*radix + n%radix;              
  }
  
  return num;
}

int main()
{
    long num;
    int D;
    while(cin>>num)
    {
        if(num<0) break;
        cin>>D;    
                
      if(isPrime(num)) 
      {
                 
      long int N_v = getReverse(num,D);
               
        if(isPrime(N_v))
                      
       cout<<"Yes"<<endl;  
       else
       cout<<"No"<<endl;                      
      }
      else
      {
       cout<<"No"<<endl;   
      }                      
    }
  
//   system("PAUSE");
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值