【PAT甲级A1015】Reversible Primes(20分)(c++)

1015 Reversible Primes (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意:

输入一个数n,和一个进制数radix,判断n是否为素数,n的radix进制数倒置后的10进制是否还为素素。如:23的二进制为10111,倒置后为11101,十进制值为29.

思路:

进制转换选择除radix取余,由于取余的顺序正好满足倒置,就直接在取余的过程中计算10进制值。(注意:原来的值n也要判断素数,1不是素数)。

参考代码:

#include <cstdio>
#include <cmath>
bool isprime(int a){
    if(a<2) return false;
    for(int i=2;i<=sqrt(a*1.0);i++){
        if(a%i==0)return false;
    }
    return true;
}
int reverse(int a,int rad){
    int sum=0;
    while(a){
        sum=sum*rad+a%rad;
        a/=rad;
    }
    return sum;
}
int main() {
    int n,radix;
    while(scanf("%d",&n)!=EOF,n>=0){
        scanf("%d",&radix);
        if(isprime(n))
            printf("%s",isprime(reverse(n,radix))?"Yes\n":"No\n");
        else printf("No\n");
    }
    return 0;
}

如有错误,欢迎指正

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值