1015. Reversible Primes (20)

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

提交代码

题意:给你一个数n,n是一个10进制数,问n是否为素数且n在d进制下反转过来(比如说13二进制形式为1101, 反转过来是1011就变成了11)是否是素数.

题解:这是一道模拟题, 先用个数组存下d进制下的数,然后在反转,在转变成10进制,看其是否为素数就好了



#include <cstdio>

bool is_prime(int n) {
    if (n < 2) return false;
    for (int i = 2; i * i <= n; ++i)
        if (n % i == 0)
            return false;
    return true;
}

bool check(int n,int d) {
    int cnt = 0;
    int ary[50];
    int tmp1 = n;
    while (tmp1) {
        ary[cnt++] = tmp1 % d;
        tmp1 /= d;
    }
    int tmp2 = 0;
    int x = 1;

    for (--cnt; ~cnt; --cnt, x *= d)
        tmp2 += x * ary[cnt];
    return is_prime(n) && is_prime(tmp2);
}

int main() {
    int n, d;

    while (~scanf("%d%d", &n, &d), n >= 0) {
        if (check(n, d) == true)
            puts("Yes");
        else
            puts("No");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值