poj1050

To the Max

Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.
Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
Sample Output

15

题意

最大子矩阵。

思路: dp

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <string>
#include <stack>
#include <vector>
#include <cmath>
#include <map>
#include <set>
#define INF 0x3f3f3f
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
inline int Max(int a,int b){ return a>b ? a : b;}
using namespace std;
int a[101][101];
int b[101];
int n;
int main(){
 //   freopen("111.txt", "w", stdout);
    int Max;
    while(scanf("%d",&n)!=EOF){
        Max=-99999999;
        for(int i=1; i<=n; i++){
            for(int j=1; j<=n; j++){
                int x;
                scanf("%d",&x);
                a[i][j]=a[i-1][j]+x;
            }
        }
        int t=0,Maxn;
        for(int i=0;i<n; i++){
            for(int j=i+1; j<=n; j++){
                memset(b,0,sizeof(b));
                for(int k=1; k<=n; k++){
                    b[k]=a[j][k]-a[i][k];
                }
                t=0,Maxn=-9999999;
                for(int k=1; k<=n; k++){
                    if(t>0) t+=b[k];
                    else t=b[k];
                    if(t>Maxn) Maxn=t;
                }
                if(Maxn>Max) Max=Maxn;
            }
        }
        cout << Max << endl;
    }
    return 0;
}

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值