复试训练——搜索——递归的应用

题目1459:Prime ring problem

时间限制:2 秒

内存限制:128 兆

特殊判题:

提交:1995

解决:836

题目描述:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.


输入:

n (1 < n < 17).

输出:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

样例输入:

6
8

样例输出:

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

提示:

用printf打印输出。

代码:

#include <stdio.h>
#include <string.h>
int n;
int ans[22];
bool hash[22];
int prime[]={2,3,5,7,11,13,17,19,23,29,31,41};
bool judge(int x){
	int i;
	for(i=0;i<13;i++){
		if(prime[i]==x) return true;

	}
	return false;
}
void check(){
	if(judge(ans[n]+ans[1])==false) return;
	int i;
	for(i=1;i<=n;i++){
	if(i!=1) printf(" ");
	printf("%d",ans[i]);
	}
	printf("\n");
}
void DFS(int num){
	if(num>1)
		if(judge(ans[num]+ans[num-1])==false) return;
		if(num==n){
		check();
		return ;
		}
		int i;
		for(i=2;i<=n;i++){
			if(hash[i]==false){
				hash[i]=true;
				ans[num+1]=i;
				DFS(num+1);
				hash[i]=false;
			}
		}
}
int main(){
	int cas=0;
	while(scanf("%d",&n)!=EOF){
	int i;
	cas++;
	for(i=0;i<22;i++){
		hash[i]=false;
	}
	ans[1]=1;
	printf("Case %d:\n",cas);
	hash[1]=true;
	DFS(1);
	printf("\n");
}
	return 0;
}

题目1460:Oil Deposit

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1496

解决:728

题目描述:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

输出:

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

样例输入:

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

样例输出:

0
1
2
2

代码:

#include <stdio.h>
char maze[101][101];
bool mark[101][101];
int n,m;
int go[][2]={1,0,
            -1,0,
			 0,1,
			 0,-1,
			 1,1,
			 1,-1,
			 -1,-1,
			 -1,1
};
void DFS(int x,int y){
	int i;
	for(i=0;i<8;i++){
		int nx=x+go[i][0];
		int	ny=y+go[i][1];	
		if(nx<1||nx>n||ny<1||ny>m) continue;
		if(maze[nx][ny]=='*') continue;
		if(mark[nx][ny]==true) continue;
		mark[nx][ny]=true;
		DFS(nx,ny);
	}
	return;
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		if(n==0&&m==0) break;
		int i;
		for(i=1;i<=n;i++){
			scanf("%s",maze[i]+1);
		}
		for(i=1;i<=n;i++){
			int j;
			for(j=1;j<=m;j++){
				mark[i][j]=false;
			}
		}
		int ans=0;
		for(i=1;i<=n;i++){
			int j;
			for(j=1;j<=m;j++){
				if(maze[i][j]=='*')continue;
				if(mark[i][j]==true) continue;
				DFS(i,j);
				ans++;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

转载于:https://my.oschina.net/u/1996306/blog/835759

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值